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PC based USB multifunction measuring device 

 

 Multi-Channel Oscilloscope (analog and digital inputs) 

 Multi-Function Generator 

 Frequency Meter 

 Spectrum Analyzer 

 Frequency & Phase Response Analyzer (two-port network) 

 Vector Antenna Analyzer (single port VNA) 

 LC Meter 

 Reflectometer 

 SDR Transceiver 

 System Clock Oscillator (VCTCXO) better than 1 PPM 

 Connects to computer and powered via USB 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Software Version – 3.21 

 

http://www.osa103.ru 

 



Contents 
Overview .......................................................................................................................................................... 1 

Oscilloscope.................................................................................................................................................. 1 

Generator ...................................................................................................................................................... 1 

Frequency Meter ........................................................................................................................................... 1 

Spectrum Analyzer ........................................................................................................................................ 1 

Frequency & Phase Response Analyzer ...................................................................................................... 1 

Vector Antenna Analyzer .............................................................................................................................. 2 

LC Meter ....................................................................................................................................................... 2 

SDR Transceiver........................................................................................................................................... 2 

Parameters In Receive Mode .................................................................................................................... 2 

Parameters In Transmission Mode ............................................................................................................ 2 

System Clock ................................................................................................................................................ 2 

Power Supply ................................................................................................................................................ 2 

Module Connections ......................................................................................................................................... 3 

USB Connection ........................................................................................................................................... 3 

Analog Channel Connection ......................................................................................................................... 3 

Digital Channel Connections ......................................................................................................................... 3 

Generator Main And Auxiliary Outputs .......................................................................................................... 4 

Generator Virtual Analog Channel ................................................................................................................ 4 

LC Meter, Vector Antenna Analyzer and Reflectometer Connections ........................................................... 4 

Mode Setting ................................................................................................................................................. 4 

Mode Jumper Settings .............................................................................................................................. 5 

Software Installation ......................................................................................................................................... 6 

System Requirements ................................................................................................................................... 6 

Procedure ..................................................................................................................................................... 6 

Software Update ........................................................................................................................................... 6 

User Interface ............................................................................................................................................... 6 

Operating Modes and Control Program ............................................................................................................ 7 

Main Window ................................................................................................................................................ 7 

Display Area .............................................................................................................................................. 7 

Oscilloscope Control Panel ....................................................................................................................... 9 

Generator Control Panel ........................................................................................................................... 9 

Generator Control Panel Display ............................................................................................................. 10 

Compact View ......................................................................................................................................... 10 

Always On Top ........................................................................................................................................ 10 

Sampling Settings ....................................................................................................................................... 10 

Memory and Number of Samples ............................................................................................................ 10 

Peak Detector.......................................................................................................................................... 10 

Averaging (Hi Res) .................................................................................................................................. 11 

Equivalent Time Sampling Mode (ETS) ...................................................................................................... 11 

Signal Display Modes ................................................................................................................................. 11 



 

 

Persistence.............................................................................................................................................. 11 

Scan Mode Display ................................................................................................................................. 11 

Trace Types ............................................................................................................................................ 12 

Background Waveforms .............................................................................................................................. 12 

Sensitivity of 50, 20, 10, 5 mV/Div .............................................................................................................. 12 

Waveforms Per Second Setting .................................................................................................................. 12 

Subtractive Dither ....................................................................................................................................... 12 

Advanced Trigger Settings .......................................................................................................................... 12 

Additional Trigger Conditions .................................................................................................................. 13 

Trigger Module Auto Measurement ......................................................................................................... 14 

Generator Modes ........................................................................................................................................ 15 

Function and Modulating Generators ...................................................................................................... 15 

Modulating Using An External Source ..................................................................................................... 15 

Arbitrary Waveform Generator ................................................................................................................ 15 

Sin (x) / x Correction ................................................................................................................................ 15 

Simultaneous Operation .......................................................................................................................... 15 

Amplitude Adjustment ............................................................................................................................. 16 

Function Generator Controls ................................................................................................................... 16 

Frequency Sweep Controls ..................................................................................................................... 16 

Pulse Generator Controls ........................................................................................................................ 16 

Arbitrary Waveform Generator (AWG) Controls ...................................................................................... 17 

Generator Settings .................................................................................................................................. 18 

Auxilliary Outputs ................................................................................................................................. 18 

Virtual Generator Channel Settings ..................................................................................................... 18 

Modulation Settings ............................................................................................................................. 18 

Generator Parameter Input Keypad ........................................................................................................ 19 

Advanced Settings ...................................................................................................................................... 20 

Serial Decoder ............................................................................................................................................ 22 

Decoder Traces in Main Window ............................................................................................................. 22 

Serial Decoder Settings Window ............................................................................................................. 22 

Binary Recorder .......................................................................................................................................... 23 

Binary Recorder Settings Window ........................................................................................................... 23 

Frequency Meter ......................................................................................................................................... 24 

Frequency Meter Settings Window .......................................................................................................... 24 

Spectrum Analyzer ...................................................................................................................................... 25 

Weak Signals Measurement.................................................................................................................... 25 

Combined Multi-Frequency FFT .............................................................................................................. 25 

Advanced Algorithm For Accurate Measurements Of Peak Level and Frequency .................................. 25 

Spectrum Analyzer Display Window ........................................................................................................ 26 

FFT Settings Window .............................................................................................................................. 27 

LC Meter ..................................................................................................................................................... 28 

LC Meter Window .................................................................................................................................... 28 

Frequency Response Analyzer ................................................................................................................... 29 



 

 

Frequency Response Analyzer Display Window ..................................................................................... 29 

Frequency Response Settings Window ................................................................................................... 30 

Default FRA Settings ............................................................................................................................... 30 

Calibration (Amplitude And Phase Normalization) ................................................................................... 30 

Connection For Calibration .................................................................................................................. 30 

FRA Calibration Window ...................................................................................................................... 31 

Changing The Sweep Speed And Number Of Samples .......................................................................... 31 

Changing The Level of Generator Output And Reference Level ............................................................. 31 

FRA As Spectrum Analyzer ..................................................................................................................... 31 

Vector Antenna Analyzer ............................................................................................................................ 32 

Antenna Analyzer Display Window .......................................................................................................... 32 

Antenna Analyzer Settings Window ........................................................................................................ 33 

Antenna Analyzer Auto Setting................................................................................................................ 33 

Open/Short/Load (OSL) Calibration ........................................................................................................ 33 

Changing The Scanning Speed And Number Of Samples ...................................................................... 34 

Changing The Oscillator Output Level And The Input Sensitivity ............................................................ 34 

Achieving Maximum Measurement Accuracy .......................................................................................... 34 

Reflectometer.............................................................................................................................................. 35 

Taking Measurements ............................................................................................................................. 35 

Calibration ...................................................................................................................................................... 36 

Zero Calibration .......................................................................................................................................... 36 

Calibrating The System Clock Frequency ................................................................................................... 36 

Opening and Saving Files .............................................................................................................................. 36 

Data Files .................................................................................................................................................... 36 

Configuration Files ...................................................................................................................................... 36 

Script Files For AWG .................................................................................................................................. 37 

Drag and Drop PVD, PVS, PVG Files ......................................................................................................... 37 

Export Image (Screen Shot Saver) ............................................................................................................. 37 

Export Text File ........................................................................................................................................... 37 

Export CSV File .......................................................................................................................................... 37 

Export Binary File........................................................................................................................................ 37 

Customize Colors and Language ................................................................................................................... 37 

Shortcut Keys ................................................................................................................................................. 38 

Quick Access To Menus ............................................................................................................................. 38 

Generator .................................................................................................................................................... 38 

Oscilloscope................................................................................................................................................ 38 

Spectrum Analyzer (FFT) ............................................................................................................................ 39 

Frequency / Phase Response Analyzer and Antenna Analyzer .................................................................. 39 

Mutually Exclusive Functions ......................................................................................................................... 39 

Technical Features ......................................................................................................................................... 40 

Multi-channel oscilloscope .......................................................................................................................... 40 

General ................................................................................................................................................... 40 

Triggering ................................................................................................................................................ 40 



 

 

Protocol Decoder ..................................................................................................................................... 40 

Multifunctional Generator ............................................................................................................................ 40 

General ................................................................................................................................................... 40 

Function Generator ................................................................................................................................. 40 

Pulse Generator ...................................................................................................................................... 41 

Arbitrary Waveform Generator ................................................................................................................ 41 

Auxilliary Digital Output ........................................................................................................................... 41 

Frequency Meter ......................................................................................................................................... 41 

Spectrum Analyzer ...................................................................................................................................... 41 

General ................................................................................................................................................... 41 

Combined Multi-Frequency FFT Mode .................................................................................................... 42 

LC Meter ..................................................................................................................................................... 42 

Frequency Response Analyzer ................................................................................................................... 42 

Vector Antenna Analyzer ............................................................................................................................ 42 

Reflectometer.............................................................................................................................................. 42 

General Parameters .................................................................................................................................... 42 

Appendix .......................................................................................................................................................... 1 

Arbitrary Waveform Generator Script Commands......................................................................................... 1 

List Of Commands ..................................................................................................................................... 2 

Macros ...................................................................................................................................................... 2 

Macro Parameters ..................................................................................................................................... 2 

Directives................................................................................................................................................... 2 

Expanding Frequency Range For FRA And AA ............................................................................................... 7 

Installing the Software In Linux (Ubuntu) .......................................................................................................... 8 

System Calibration And Debug Information ...................................................................................................... 9 

System Calibration Window .......................................................................................................................... 9 

Calibration Procedure ................................................................................................................................... 9 

Preparation ................................................................................................................................................ 9 

Generator Calibration ................................................................................................................................ 9 

Phase, Offset And Gain Matching For Interleaving ADCs ....................................................................... 10 

Setting Subtractive Dither Compensation ................................................................................................ 10 

Calibration Of The System Frequency (VCTCXO) .................................................................................. 10 

Checking The Digital Channels ............................................................................................................... 10 

DAC Distortion Correction ....................................................................................................................... 10 

Exit and Store Calibration ........................................................................................................................ 10 

Debug Information ...................................................................................................................................... 10 

USB ......................................................................................................................................................... 10 

Strobe Mode (ETS) ................................................................................................................................. 10 

 

 

 

 



 

1 

Overview 

Oscilloscope 

One analog channel (A1) + four digital channels (D1 ... D4) + one virtual analog generator channel (A2). 

Analog channel (A1): 

 Impedance 50 ohms. 

 Bandwidth 1 Hz ... 400 MHz (supports only AC coupling). 

 Sampling rate 200 MHz (real time), 10 GHz (strobe mode) 

 Basic input sensitivity 0.1 V / Div. (user settings for scale magnification eg for external probe). 

Memory up to 40,000 samples per channel. 

Digital channels (D1 ... D4) have adjustable trigger thresholds between 0 ... 13 V and a real time sampling 
rate of 1.6 GHz. 

The analog generator channel provides a visualisation of the generator output and can also be used as a 
triggering source. 

Additional flexible digital triggering modes. 

Fully digital equivalent time sampling (ETS) mode that provides stable triggering from noisy and high 
frequency (up to 1 GHz) signals. 

Peak detector and a high resolution mode. 

Generator 

Function generator (sine, square, triangle, saw):  0.001 Hz ... 50 MHz within +/- 0.5 dB flatness. 

Usable to 100 MHz with less flatness. 

AM, FM, PM modulator. 

Signal summation and additional built-in modulating signal generator 0.001 Hz ... 100 MHz. 

Frequency sweep in synch with the oscilloscope sweep. 

Switchable sin (x) / x correction. 

Pulse generator 5 ns ... 5 s 

Noise generator. 

Arbitrary waveform generator with a script language describing waveforms.  

Small under/overshoot and high slew rate pulse signals. 

Auxilliary multi-function digital output. 

Frequency Meter 

Measurement of frequency from the input of any channel and from oscilloscope synchronization. 

8 digit display in the frequency measuring mode. 

Constant relative accuracy of frequency measurement in the whole range (reciprocal counting).  

Pulse counting mode. 

Period measurement 

Spectrum Analyzer 

Principles of Operation - FFT, Combined multi-frequency FFT that forms a spectrogram to 1 GHz.  

Adjustable size, 9 window functions, averaging and scaling.  

Selection of units for vertical measurements with different impedance connections.  

Advanced algorithm for accurate measurements of the peak level and frequency. 

Pure own spectrum (no internal parasitic spectral components).  

Subtractive dither Technique. 

Frequency & Phase Response Analyzer 

Principles of Operation - sweep and tracking synchronous digital quadrature receiver. Two port network 
transmission coefficient measurement. 

Measures amplitude and phase characteristics with linear or logarithmic scale and customizable range.  
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Calibration (amplitude and phase normalization). 

Frequency Range - 100 Hz ... 100 MHz. 

Dynamic range - 90 dB (10 kHz ... 60 MHz). 

Vector Antenna Analyzer 

Principles of Operation - sweep and tracking synchronous digital quadrature receiver. Measurement of the 
complex impedance of a DUT (device under test) using the shunt-thru method. Frequency Range - 10 kHz ... 
100 MHz. Open/Short/Load (OSL) calibration and "mathematical subtraction" of the connecting cable. 
Measurement (calculation) of VSWR, Return Loss for cables (lines) with user defined  Zo in the range of 
10…320 Ohms. Calculation and construction schedules SWR, Return Loss, Q, Rs, Xs, | Z |, Phase Z, Rp, 
Xp. 

LC Meter 

Measures capacitance, capacitor effective series resistance (ESR) and inductance. 

Capacitance range:  0.5 pF ... 30000 uF. 

ESR range (C > 0.5 uF):  50 milliohms ... 1 ohm. 

Inductance range: 50nH ... 3 H. 

SDR Transceiver 

The device can operate as a transceiver (DDC / DUC transceiver) in conjunction with programs supporting 
Winrad digital radio protocol. Tested with HDSDR programs, Zeus Radio ver 2.9.3, SDRuno, SDRSharp ver 
1361. 

Parameters In Receive Mode 

ADC Sampling:  200 MSPS, 8-bit. 

Minimum discernable signal MDS (500 Hz):  -97 dBm. 

ADC overflow level:  +2 dBm 

Input frequency range:  1 Hz ... 400 MHz with 3 dB flatness (unfiltered input, anti-alias filters required) 

Intermodulation (IMD3):  60 ... 70 dB. 

Panadapter maximum span:  65 kHz 

Parameters In Transmission Mode 

Max output power: +5 dBm. 

Output frequency range:  DC ... 60 MHz with 1 dB flatness. 

AM, FM, LSB, USB, CW modes. 

Transmission mode is implemented in the module and requires connection of an external microphone 
amplifier for voice. 

System Clock 

Voltage controlled temperature compensated crystal oscillator (VCTCXO) with accuracy < 1 PPM. 

System clock calibration function provided via software. 

Power Supply 

The module is powered from the USB port and requires no additional power supply. 
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Module Connections 

 Module to PC connection via micro USB. 

 Analog input channel connection via BNC (optional SMA). 

 Generator output connection via BNC (optional SMA). 

 Auxiliary output connection (2x header pins 2.54 mm spacing. 

 Digital input channels connection (5x header pins 2.54 mm spacing. 

 Jumpers for setting the operating mode (2 x 3-way header pins  2.54 mm spacing. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

USB Connection 

The module connection to the PC uses a USB micro B connector. The module is powered from the USB port 
and, in some modes of operation, the current consumption can be up to 420 mA. A quality USB cable should 
be used. Minimise the cable length (no more than 1.5 m) and power conductor resistance (not more 2x0.3 
ohms). It is recommended to have ferrite filters on the cable. Attention should also be paid to cleanliness of 
the contacts and the reliability of the connectors. 

Analog Channel Connection 

The analog channel input (A1) uses a coaxial BNC female connection (or optional SMA female). The input 
impedance is 50 ohms. Best results are achieved when using a coaxial cable with characteristic impedance 
of 50 ohms.  The input can be configured with a high impedance (5kR || 8 pF)  see also: Mode Selection 
Jumpers.. 

Exceeding the following on the analog input may damage the module: 

 Maximum AC input 0.15 W (22 dBm). 

 Maximum DC input voltage 3.5 Vdc. 

Digital Channel Connections 

There are four digital connections which share a common ground. Connections are via 2.54mm header pins. 
Wires for digital connections should be of minimum length. When measuring high-frequency digital signals 
and / or signals with high slew rate, the wire length must not exceed 15-20 cm. Ground wires should be as 
short as possible. 

Exceeding 100 Vdc on the digital inputs may damage the module. 
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Generator Main And Auxiliary Outputs 

There is a main generator and an auxilliary generator output. The main generator output uses a coaxial BNC 
female connection (or optional SMA female). The auxilliary generator output uses 2.54mm header pins 
(output and ground). The output impedance of these outputs is 50 ohms. Best results are achieved when 
using cable with characteristic impedance of 50 ohms. In some cases (eg. low frequency and / or a short 
connecting line), an unmatched cable can be used. 

The generator output is short circuit protected. However, do not connect voltage 
sources to the generator output eg. in LC Mode ensure capacitors are discharged 
before connecting. 

Generator Virtual Analog Channel 

Emulates a second analog generator output channel (A2 Channel) connected virtually to the generator 
output. Digital connection of the generator output to a virtual analog channel is made at the lowest level 
within the FPGA chip. This provides a visualisation of the main generator output wave as well as an 
alternative trigger source. 

Emulations supported: 

 All sweep, all sensitivities, all modes of channel sampling. 

 AC / DC coupling. 

 Channel bandwidth limitation. 

 All trigger settings. 

 Generator waveforms and amplitude in all modes. 

 Switchable sin (x) / x correction of generator output. 

 Adjustable external load of the generator is emulated. 

 Exact matching and adjustment of the time offset with the real channel (up to fractions of a 

nanosecond). 

Limitations: 

 Accurate emulation of generator amplitude and phase is performed up to a frequency of 50 MHz. 

 Due to the implementation principle, the virtual channel is not displayed in the stroboscopic mode. 

 The noise level is not fully emulated (less than the real channel noise). 

 Distortion and harmonics introduced by real DAC, ADC, and analog paths are not emulated. 

LC Meter, Vector Antenna Analyzer and Reflectometer Connections 

LC Meter, Vector Antenna Analyzer and Reflectometer modes use the analog channel input connection. 
Each mode is configured according to the Mode Selection Jumpers and respective tool selection in the 
software program. 

Mode Setting 

There are 2 mode switches J1 and J2. The switches are jumpers which can be in one of 3 states: 

 pins 1-2 only 

 pins 2-3 only 

 no connection. 
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Mode Jumper Settings 

J1 J2 Mode 

1-2 1-2 Oscilloscope (analog channel input impedance: 50 ohms). 

  Generator 

  Frequency Meter 

  Spectrum Analyzer. 

  Frequency Response Meter 

none 1-2 Oscilloscope (analog channel increased input impedance:  ~ 5 kohms || 8 pF). 

  Generator. 

  Frequency Meter. 

  Spectrum Analyzer. 

  
Frequency Response Analyzer (input impedance- ~ 5 kohms || 8 pF, with a reduction 
of the dynamic range) 

2-3 2-3 LC Meter. 

  Vector Antenna Analyzer. 

  Reflectometer. 

2-3 none LC meter (small capacity measuring mode) 
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Software Installation 

System Requirements 

The software is compatible with the Windows (from XP to Win 10) operating system. It can also be run in 
Wine Linux environment (see: Installing software in Linux Ubuntu). 

The software does not impose any additional hardware requirements on the computer, does not require 
installation of additional software packages, and takes about 10 MB on the hard disk space. 

The software does not require installation on the PC. The program is simply placed in a user folder on the 
hard drive or removable media. The program automatically generates a .ini file in the program folder to store 
the settings.  A log file for arbitrary waveform scripts is also saved in the program folder. The program folder 
should be placed in a user accessible area, not in Program Files directory or other directories with restricted 
access rights. 

The display window can be scaled over a wide range. The minimum recommended computer screen 
resolution is 800 x 600. 

Procedure 

 Download the software and drivers zip file from www.osa103.ru/en/software. 

 Unzip the downloaded folder to a user accessible folder ("yourName") on the hard / removable drive. 

 Connect the module to the USB. Power light illuminates and PC auto detects new device. 

 Install the USB drivers. The operating system should automatically set-up the drivers for the new 

device. Device drivers are digitally signed and can be automatically installed through Windows 

Update. Drivers are also located in the program folder or subdirectory ../Drivers or they can be 

downloaded from the manufacturer's website USB chip www.ftdichip.com/Drivers/D2XX.htm. 

 To start the software, open "yourName" folder and run the executable Osa103.exe.  For 

convenience create a shortcut to Osa103.exe and put it on the desktop. 

 The initialization process takes less than 10 seconds. 

 Assuming mode is set for oscilloscope, press [RUN] button to start the oscillosope. 

In some cases, Windows XP may need to install a previous version of the driver. The recommended version 
is the CDM 2.08.14 driver. 

To run more than one module on the same PC, itis necessary to make a copy of the executable file with a 
different name. 

Software Update 

The device does not store the firmware in the off state. Full installation of the firmware is performed by the 
control program during each start (it takes less than 10 seconds). Therefore, to update all the software it is 
sufficient to replace the executable file .exe file with a newer version. 

User Interface 

The software mainly uses conventional UI widgets for controls and menu selections (buttons, choosers, 
scroll bars etc.). The user actions (eg. mouse operations) for these intuitive widgets are therefore not 
described in this manual. However, there are certain UI widgets specific to the signal traces (eg cursors) 
which are fully described. 

 

  

http://www.osa103.ru/en/software
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Operating Modes and Control Program 

Main Window 

The screen shot below shows the main window with oscilloscope mode activated.  This is the default 
operating mode when all other modes (LC Meter, Spectrum Analyzer (A1), Frequency Response Analyzer 
and Antenna Analyzer) are unchecked in Menu-> Tools. The other operating modes are described in their 
respective sections later in the manual. 

 

 

Display Area 

1.1. Vertical sensitivity (voltage per division). 

1.2. Sweep speed (time per division). Information on the enabled averaging mode (Hi Res) and the number 
of averaged samples (HR ...), peak detector (PD), stroboscopic mode (ETS - Equivalent Time Sampling) or 
using sin(x) / x. 

1.3. Identifies the trigger channel, trigger level and whether extended triggering is enabled (T+). 

1.4. Status indicator: 

 Module initializing. 

 Idle (Sweep not running). 

 Waiting for trigger and the end of a set of samples. 

 Receiving and displaying waveforms. 

1.5. Additional information line.  Toggle line on / off using Menu->View-> View-> Extra Info or Ctrl + I. 

From left to right: 

 The total size of the oscilloscope grid in pixels. 

 Primary system supply voltage from the USB connector. 
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 The number of samples. Information includes: averaging mode (Hi Res) and the number of samples 

averaged (HR ..), peak detector (PD), stroboscopic mode (Equivalent Time Sampling -ETS) or 

sin(x)/x in use. 

 The number of waveforms displayed per second (WPS - waveforms per second) or number of 

discarded waveforms (received from the device, but not displayed because of the lack of computer 

speed). For WPS settings File-> WPS (max). 

1.6. Slider to adjust analog channel zero level on vertical scale. Drag up / down using left click and hold on 
icon. 

 The letter "Z" has reduced brightness if the input signal is overshooting (departing from the grid or 

deviating from a DC component of more than 0.45 V). 

1.7. Slider to adjust analog channel trigger level (A1 or A2.). Drag up / down using left click and hold on icon. 
The icon incudes a letter "T" when triggering is enabled for this channel, otherwise icon is blank. 

1.8. Vertical time and horizontal voltage measuring cursors (see 1.11 and 1.12). The displayed cursors can 
be set as single, double or none. Single cursors provide one vertical time cursor and one horizontal voltage 
cursor.  Double cursors provide two vertical time cursors and two horizontal voltage cursors. Cursors are 
enabled / disabled using Menu-> View-> Cursors or Double Cursors or none. Position cursors up / down or 
left / right by left using click and hold on cursor. 

1.9. Vertical line at the trigger time point. 

1.10. Display of parameters / measurements (first line under the grid displays up to 4 data items).  

When the Frequency Meter is off, the data items are from left to right: 

 Start of viewing time (the left edge of the grid) with respect to the trigger time. 

 The sampling frequency. 

 The number of grid divisions occupied by the signal trace (can vary from 10 fast scanning or 0 with 

zoomed waveform). 

 The digitizing sampling rate. 

The second, third and fourth data items above are enabled / disabled using Menu-> View-> View-> Sampling 
Info or Ctrl + Y. 

When the Frequency Meter is on in frequency mode, the fourth data item is replaced to show the measured 
frequency (F(T)). 

When the Frequency Meter is on in period & counter mode the, second data item becomes the period 
measurement (T(T) and the fourth data item becomes the event count (N(T). In this case, third data item is 
blank. 

1.11. The second text line under the grid are cursor measurements with respect to time.  The data on this 
line depends whether single cursors, double cursors or no cursors is selected (see 1.8).  

With single cursor from left to right: 

 Time at cursor position (T). 

 The inverse value of the time (1/T) in frequency units. 

With double cursors from left to right: 

 Time at left hand cursor position (T1). 

 Time at right hand cursor position (T2) 

 Time difference between cursors (dT) 

 The inverse value of the time difference (1/dT) in frequency units. 

1.12. The third and the fourth text line under the grid are auto-measurements and cursor measurements with 
respect to voltage for analog inputs A1 and A2 respectively. These lines are only displayed when A1 and/or 
A2 are enabled using Menu-> View-> A1 and/or A2 (Generator). 

The first three data items on the lines from left to right: 

 Signal peak to peak voltage (Vpp). 

 The constant voltage component of the signal (Vdc). 

 Signal RMS voltage without DC component (Vrms). 

The fourth data item on the lines depends on the cursor setting (see 1.8). It is either the voltage at horizontal 
single cursor position (V) or voltage difference between horizontal double cursors positions (dV). 

1.13. Scroll bar to adjust horizontal position of the displayed waveforms. 
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1.14. Display showing the trigger auto-measurement. In this case, auto-measure of the signal period. 
Enabled using Menu-> View-> View-> Trig. Event Time or Ctrl + E. 

Oscilloscope Control Panel 

2.1. Button [RUN] to turn continuous sweep on / off. Unpressed is off, pressed is on. 

2.2. Button [SINGLE] to start single sweep (only when [RUN] is off). 

2.3. Sweep status indicator. 

2.4. Buttons to set the required sweep speed (time/Div). Can also be be adjusted (zoomed) by pointing in the 
grid area and using the mouse wheel. 

2.5. Channel A1 enabled / disabled indicator.  Can also be used to enabled / disable the channel using 
double click on indicator. Alternatively use Menu->View-> A1 or Ctrl + 1. 

2.6. Button to select A1 division ratio (V/Div or x10). Unpressed is V/Div, pressed is x10. Alternatively use 
Menu-> Options-> Probe A1 to set probe value. 

2.7. Button to enable / disable built-in 25MHz LPF on A1 channel. The LPF is in the digital domain and does 
not suppress aliases above 100 MHz. Unpressed is filter disabled, pressed is filter enabled. 

2.8. Button to select AC / DC input coupling (not active in OSA103 Mini - input is always AC coupled). 

2.9. Buttons to set the required voltage sensitivity for the A1 channel. Unpressed is not selected, pressed is 
selected. 

2.10. Button [ON] to turn triggering on / off. Unpressed is triggering off, pressed is triggering on. When on, 
the trigger level slider (1.7 above) is also enabled. 

2.11. Triggering status indicator (illuminated shows triggering on, greyed shows triggering off). 

2.12. Button [Trigger] to open the Trigger Settings window. Alternatively use Menu-> Options-> Trigger or 
Ctrl + T. 

2.13. Drop down menu box to select channel for the trigger source. Box displays current setting. 

2.14. Button to select positive or negative slope triggering. Unpressed is positive slope, pressed is negative 
slope. 

2.15. Button [Auto] to turn automatic triggering on / off. Unpressed is Normal triggering mode where the 
oscilloscope triggers on the required triggering condition. Pressed is Auto triggering mode where the 
oscilloscope generates its own automatic triggers (not synchronous to the signal under test) if the required 
trigger condition doesn’t occur within a predetermined amount of time. 

2.16. Button [T+] to enable additional triggering modes. Unpressed is normal triggering, pressed enables 
additional triggering. See also: Advanced Trigger Settings. 

2.17. Button [S] to turn on strobe mode (Extended Time Sampling ETS). Unpressed is strobe mode off, 
pressed is strobe mode off. Only available for sweep rates of 0.2 ns/Div ... 0.2 µs/Div). 

Generator Control Panel 

Screen shot shows function generator mode. See Generator Modes for other modes. 

3.1. Button [ON] to turn generator on / off. Unpressed, generator is off, pressed, generator is on. 

3.2. Buttons to select generator mode. Unpressed, the generator is in function generator mode. 

Pressed, the generator provides one of the following modes: 

 Modulation [Mod.] (see Generator Settings). 

 Sweep generator [Swp.] in synch with the oscilloscope sweep. 

 Pulse generator [Pulse]. 

 Arbitrary Waveform generator [AWG]. 

3.3. Display of current generator frequency setting. To adjust frequency, use scroll bars below frequency 
display or left double click on the frequency digits to bring up a Parameter Input keypad window. 

3.4. Display of current generator amplitude setting. By default, the displayed value is Vpp (peak-to-peak 
voltage) and Vrms (RMS voltage) for the case when there is no load at the generator output. To adjust 
amplitude use scroll bar to right of amplitude display or left double click on the amplitude digits to bring up 
the Parameter Input keypad window. The displayed units can be changed (see Advanced Settings). 

3.5. Buttons to select generator frequency band (upper frequency of band). Unpressed is not selected, 
pressed is selected. 

3.6. Button to turn the noise generator on / off. Unpressed is off, pressed is on. 

3.7. Buttons to select the generator waveform. Unpressed is not selected, pressed is selected. See 
Generator Modes. 
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3.8. Scroll bar for coarse adjustment of the function generator frequency within the chosen frequency band. 
For Modulation, Sweep, Pulse and AWG modes see control descriptions in Generator Modes. 

3.9. Scroll bar for fine adjustment of the function generator frequency within the chosen frequency band. For 
Modulation, Sweep, Pulse and AWG modes see control descriptions Generator Mode. 

3.10. Scroll bar to adjust generator amplitude (voltage). 

Generator Control Panel Display 

Menu-> View-> Generator. Hides / shows the generator control panel on main window (enlarges the signal 
display area). Check to show, uncheck to hide. Alternatively, left double click at bottom of the signal display 
area to toggle panel display. 

Compact View 

Menu-> View-> Compact view. Hides / shows the generator and oscilloscope control panels. Allows the 
signal display area to fill the whole screen. Check to show, uncheck to hide. Alternatively, left double click at 
top of the signal display area to toggle view. The program remembers the position and size of a compact 
window making it easy to toggle between views to make setting adjustments 

Always On Top 

Menu-> View-> Always On Top. Places the main window on top of other application windows. Check to 
enable, uncheck to disable 

Sampling Settings 

Open with Menu-> Options-> Sampling. 

 

 

 

 

 

 

 

 

 

 

 

Memory and Number of Samples 

Check to select the required number of samples (one of 2000 ... 40000). 

The value corresponds to the number of samples during normal digitization without peak detector or 
averaging Hi Res (and in fact is the number of bytes allocated for the analog channel). When the peak 
detector is on, each sample consists of a 2 samples, and when Hi Res averaging is on, the samples are 16-
bit values. The number of samples in these modes will be half the set value. 

With digital channels on and a sweep speed 2 ns / div ... 0.1 µs / div, digital channels sampling rate is 
1.6GHz. In this case, the analog channel sampling frequency is 200 MHz (i.e., 8 times less) so the number of 
analog channel samples is reduced by 8 times. 

The maximum value of 40000 is reached only when no more than 1 analog channel + 2 digital channels (pair 
D1, D2 or D3, D4). When all 6 channels are enabled, the maximum value will be 20000 per channel. 

Setting the number of samples has a high priority. On the "fast" sweep the oscilloscope will not automatically 
reduce the number of samples (to place signal in 10 horizontal divisions). At the same time, the captured 
signal on fast sweeps can take thousands of horizontal divisions. To view the entire signal, the horizontal 
position control can be used to scroll along the waveforms or stop the sweep and compress the signal by 
switching the scanning speed button. This is done to make the result unamibuous when using: the spectrum 
analyzer mode (FFT samples), the protocol decoder (the number of decodable data), the sweep frequency in 
synch with the sweep, to improve the accuracy of auto measurements etc. 

Peak Detector 

Check to enable, uncheck to disable. Alternatively use Ctrl + P to toggle. 

Signal digitization mode for registering short guaranteed emissions (glitches) signal and suppress aliasing. 
Always included maximum sampling frequency (200 MHz to 1.6 GHz analog and digital channels) in the 
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memory are recorded the maximum and minimum signal values over each sample interval and these values 
are used to display the waveform. This mode is suitable for both analog and digital channels. Due to the 
operating principle can visually enlarge the waveform noise. Mode is enabled (and it makes sense) only 
when the sampling frequency is less than 200 MHz. 

Averaging (Hi Res) 

Check to enable, uncheck to disable. Alternatively use Ctrl + A to toggle. 

High-resolution averaging mode (Hi Res) allows the resolution of the oscilloscope to be increased and 
reduce noise by automatically reducing the bandwidth. In this mode the maximum sampling rate (200 MHz) 
is always used and the averaged 16-bit signal values over each sample interval are written to memory and 
used to display the waveform. The number of averages is automatically chosen by the oscilloscope 
depending on the sweep speed setting and the number of samples and may reach 16777216 (2 ^ 24). 
Efficiency increases with decreasing sweep speed. This mode applies only to analog channels. The mode 
can only be enabled when the sampling frequency is 200 MHz. 

Equivalent Time Sampling Mode (ETS) 

ETS is intended to observe high-frequency periodic signal (a frequency greater than 5 MHz). The module 
uses a fully digital principle of stroboscopic triggering that provides stable synchronization noisy and complex 
pulse signals. It allows triggering, selection and monitoring of signals near the noise floor. It provides an 
increase in effective number of bits of digitization. Stably synchronizes signals to hundreds of Megahertz 
(has no restrictions associated with a comparator speed or in the classical implementation TDC). 

 Mode can be used with sweep speeds of 2 ns / div ... 0.2 µs/Div. 

 ETS is automatically on for sweep speeds 2 ns/Div ... 20 ns/Div (when digital channels are turned 

off). 

 ETS can be turned on / off using the [S] strobe button on the oscilloscope control panel. 

 Generator frequency sweep in synch with the oscilloscope sweep should be switched off. 

 It is recommended to increase the number of signal samples (especially for signals at frequencies 

below 10 MHz and / or when using digital channel triggering). 

 Advanced trigger modes [T+] are not applicable. 

 The generator virtual channel cannot be displayed in the stroboscopic mode. 

 When Spectrum Analyzer (FFT A1) is enabled, the Combined Multi-Frequency FFT will be 

performed. 

Signal Display Modes 

Open with: Menu-> View-> Draw Mode. 

 

 

 

 

 

 

 

 

 

Persistence 

Check to enable, uncheck to disable. Alternatively use Ctrl + H to toggle. 

Causes persistence of the signal trace (emulates phosphor screen). 

Scan Mode Display 

If the sweep speed is set to 0.1 sec/Div ... 1000 sec/Div and triggering is turned off, the oscilloscope turns on 
Scan Acquisition mode to continuously monitor signals that change slowly. 

The Scroll selection in the display mode menu enables / disables scroll view in the Scan Acquisition mode. 
Check to enable, uncheck to disable. Alternatively use Ctrl + L to toggle. 
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With scroll disabled, the displayed waveform updates from the left to right on the screen and erases old 
points as it displays new points. A moving, blank section of the screen separates the new waveform points 
from the old. 

With scroll enabled, the displayed waveform scrolls left in time (eg like a chart recorder). 

Trace Types 

Check to enable, uncheck to disable one of the following signal trace types: 

 Dots. 

 Vector values. 

 Sin (x)/x compensated (only analog channels for signals with a sampling frequency of 200 MHz). 

Background Waveforms 

The following menu items are used to control the background waveform: 

 Menu-> View-> B.G. Oscillogram (check to enable, uncheck to disable BG). 

 Menu-> View-> Main <-> B.G. Oscillogram (press to toggle between main and BG. Alternatively use 

Ctrl + B). 

 Menu-> View-> Clear B.G. Oscillogram (press to clear BG waveforms). 

Provides a mechanism for rapid storage and display of waveforms for comparison with newly captured ones. 
Background waveforms are displayed dimmed. Aligned with the main waveforms at the time of triggering. 
The displays have independent adjustment of the vertical position (level zero). Scaled horizontally (time) and 
vertically (voltage) in synch with the basic waveform. When the data is saved to a file it is stored together 
with the basic waveform. 

When working with background waveforms, the window title displays the sequence numbers (counted from 
the start of the module launch) for the current and the background waveforms. When saving or opening a 
data file, the name in the window title will also be double. The suffix _BG (Background) is added to the name 
of the background waveforms. 

Sensitivity of 50, 20, 10, 5 mV/Div 

The module hardware has a single base sensitivity of 100 mV/Div. Other sensitivity values are achieved 
using digital zoom. These values are primarily intended for operation in the average mode (Hi Res) and in 
the ETS mode, where, due to the principle of operation, the noise level is significantly reduced. 

Waveforms Per Second Setting 

Open with: Menu-> File-> WPS (max.).  

In some settings, the number of the displayed waveforms per second can be more than 100. To reduce CPU 
usage it is not recommended to set “No Limit”. The recommended value is 40. 

Subtractive Dither 

The module uses a Subtractive Dither technique. This adds pseudo random noise to the analog signal at the 
ADC input and then digitally subtracts this noise after ADC. 

 Dramatically reduces the differential nonlinearity of the ADC. 

 De-correlates the unavoidable feed-through from the digital outputs of the ADC to its input. 

 Reduces the number and level of ADC spurs, increases SFDR during spectral analysis (especially 

for low level signals). 

 Increases the efficiency of the Hi Res mode, allowing observation of low level signals. 

 Practically does not increase the ADC noise level. 

 Helps to obtain the FRA dynamic range of more than 90 dB (using processing gain). 

Advanced Trigger Settings 

Full digital triggering is used with a high accuracy, no calibration, capability to operate with difficult conditions 
and flexible settings. 

Open with: Menu-> Options-> Trigger or Ctrl + T. 
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1. Pre-Trigger sets the number of grid divisions before triggering . 

2. Noise Rejects / Double Trigger sets the trigger noise reduction (hysteresis) or double level for runt and 
slew time trigger. 

3. Scroll bar for adjusting the trigger threshold level on D1, D2, D3 channels. 

4. Scroll bar for adjusting the threshold level on D4 channel. 

5. Button to enable equal adjustment of digital channels (locks the two scroll bars). Unpressed is disabled, 
pressed in enabled. 

Additional Trigger Conditions 

Enabled by pressing [T+] button on oscilloscope panel. 

6. Buttons to select pulse triggering (rising or falling edge). Unpressed is not selected, pressed is selected. 

 Starts sweep only if the pulse duration satisfies the interval T and signal En = 1 at the time of 

crossing the trigger level. 

 For all modes, there are two buttons (one for rise and one for fall edge triggering). These buttons 

and Trigger rise / fall button on the oscilloscope control panel will change together. 

7. Buttons to select period triggering (rising or falling edge). Unpressed is not selected, pressed is selected 

 Starts sweep only if the pulse period satisfies the interval T and signal En = 1 at the time of crossing 

the trigger level. 

8. Buttons to select triggering on runt length (rising or falling edge). Unpressed is not selected, pressed is 

selected. A runt is a condition where the signal crosses a first threshold but does not cross a second 
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threshold before re-crossing the first again (eg. A rising logic signal falls to reach level for 1 or when falling 

fails to reach level for 0). 

 The sweep starts only if the runt duration satisfies interval T and signal En = 1 at the time of crossing 

the trigger level. 

 Applies only to analog channels. 

9. Buttons to select slew time triggering (rising or falling slope). Unpressed is not selected, pressed is 
selected. 

 Sweep starts only if the rise / fall time of the signal between the thresholds satisfies the interval T 

and signal En = 1 at the time of crossing the trigger level. 

 Applies only to analog channels. 

10. Buttons to select triggering by pulse number N separated by period T (count N on rising or falling edge). 
Unpressed is not selected, pressed is selected. 

 Pulses whose duration satisfies duration T, reset the internal counter. Pulses whose duration does 

not satisfy duration T, increase the internal counter. A trigger pulse is generated when the counter 

reaches the specified value N and when the condition En = 1. 

11. Buttons to select triggering by pulse number N separated by En signals (count N on rising or falling 
edge). Unpressed is not selected, pressed is selected. 

 A low En level resets the internal counter. A high level enables the counter allowing pulses to 

increase the value of the internal counter. A trigger pulse is generated when the counter reaches the 

specified value N. 

12. Buttons to select triggering by video signal line number (PAL, SECAM, NTSC). Unpressed is not 
selected, pressed is selected. 

 The video signal format is detected automatically. 

 Trigger level must be set manually to the sync part of a composite video signal (usually it’s a lower 

third part of the video signal amplitude). 

Items 6 to 12 are mutually exclusive selections. 

13 Button to set the time interval T (with items 14, 15 and 16 below). 

 Unchecked:  T ignored 

 Grayed:  T outside the set interval. 

 Checked:  T inside the set interval. 

14. Buttons to select range for T. Greyed (inactive) if 13 is unchecked. When active, unpressed is not 
selected, pressed is selected. 

15. Scroll bar to adjust the start value for T. 

16. Scroll bar to adjust the end value for T. 

17. Scroll bar to adjust the required number of the pulses to count N or video line number (depending on the 
type of triggering selected). 

18 Check boxes to select the logical expression for the En signal. Unchecked is not selected, checked is 
selected. 

In addition, the logical level of other channels is taken into account at the time of rising or falling edge to 
make a decision to generate a trigger pulse or not. When the logical expression for En = 1 (true) trigger pulse 
can be generated (and sweeping can start). Analog channels are brought to logical levels with corresponding 
trigger levels and hysteresis (if the signal is above the trigger level then the logic level for the channel is 1 or 
true). 

19. Controls to specify the logical expression used in 18 above. 

Trigger Module Auto Measurement 

Open with: Menu-> View-> View-> Trig Event Time.  

Provides a display of the trigger time on the waveform trace. For this measurement, triggering must be on 
and the trigger conditions must be met. Turning on additional trigger modes is optional (pressing the [T+] 
button). The duration is measured by a hardware counter with high accuracy independent of the sweep rate 
of the oscilloscope. Measurement range is 5(10) ns ... 21 s (with a resolution of 5 ns). 

The measured parameter is determined by pressing the trigger selection buttons described above: 

 6 duration of positive or negative pulse. 
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 7 period. 

 8 the duration of the positive or negative runt. 

 9 the slew time. 

Turning on the averaging mode (Hi Res) lowers the resolution of this automatic measurements to 1/Fs, 
where Fs - set frequency oscilloscope samples. 

Generator Modes 

There are five independent digital generators implemented in the module. 

 Function Generator. 

 Modulating Generator (similar to the function generator). 

 Pulse Generator. 

 Arbitrary Waveform Generator (scripted waveforms). 

 Noise Generator 

Function and Modulating Generators 

Uses DDS technology (direct digital synthesis) with a phase word length of 48 bits and and operates at a 
clock rate of 400 MHz. All types of modulation and frequency sweep are fully digital. For frequencies less 
than 1 MHz it is possible to select one of five standard waveform forms both as a carrier frequency, and 
modulating signal (sine, square, triangle, forward slope sawtooth and downward slope sawtooth. For 
frequencies above 1 MHz only sinusoidal waveform is supported. 

Modulating Using An External Source 

It is possible to modulate a function signal from an external signal received through the oscilloscope analog 
input channel. The modulation and the modulated signals can be simultaneously observed on the 
oscilloscope using Virtual Analog Channel Generator. Alternatively it can be modulated (shift keyed) by a 
signal received at the input of a digital channel. 

Modulation is performed digitally after digitizing the modulating signal. To maximize the dynamic range of the 
ADC set the vertical sensitivity and level zero so that the modulating signal occupies the maximum number 
of divisions vertically, but not off the scale. It is recommended to enable the limited bandwidth mode. 

Modulation by an external signal does not affect this oscilloscope channel. Enabling / disabling the channel 
display, turning off the sweep, changing the sweep speed and the changing the sampling mode (averaging 
or peak detector) do not affect the modulation result. The modulation signal is always taken at the maximum 
sampling rate of 200 MHz. Modulation by an external signal does not work in the strobe mode. 

Arbitrary Waveform Generator 

Executes the script commands (see Arbitrary Wave Generator Script Commands in the Appendix) with 
frequency up to 200 MHz and can generate complex and long-lasting signals with minimal commands and 
memory. The script generator has a mechanism for outputting marks (short positive pulses) to the 
oscilloscope channel D1. A label is generated when executing a script command at a specific address. 
Addresses (names) of all available labels are contained in the script file and are loaded into the drop-down 
list when loading (compiling) the script file. Labels are convenient to use when debugging a script, for 
synchronization, a frequency counter and counter can work on the labels, etc. For guaranteed observation of 
the marks, it is recommended to enable the peak detector mode. 

Sin (x) / x Correction 

The module uses a hardware sin (x) / x frequency response correction. By default the correction is 
automatically turned on for sinusoidal output signals to produce a constant amplitude up to 50 MHz, and is 
turned off for pulse signals to give better transient characteristics. Sin (x) / x can be manually turned on / off 
(see Generator Settings). 

Simultaneous Operation 

In some modes, different digital generators will operate simultaneously, providing signals on the main and 
auxilliary outputs. Various combinations are possible, for example, it is possible to turn on modulation of a 
function generator with a script generator of arbitrary waveform, and to use the pulse generator on another 
output. Since different generators share one control panel, in some cases, during adjustments it will be 
necessary to use the generator [ON] button to turn off the off generator in order to prevent wrong signals 
reaching the output. 
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Amplitude Adjustment 

The generator amplitude is adjustable down to 0V, but it should be noted that the adjustment is made at the 
expense of DAC bit width. For small amplitude signals it is recommended to use an external attenuator. 

Function Generator Controls 

The function generator controls have been described previously (see Generator Control Panel in Main 
Window). 

Modulation Controls 

(see also Modulation Settings in Generator Settings). 

 

 

 

 

 

 

 

 

1. Set carrier frequency. 

2. Carrier frequency scroll bar (fine adjustment). 

3. Carrier frequency scroll bar (coarse adjustment). 

4. Information on the modulation signal (in this case - the FM deviation). 

5. Information on the modulation signal (in this case - the modulation frequency). 

Double-click on data items 4 or 5 to open the Generator Settings window. Turning on the noise generator 
makes sense only with AM modulation or summation of signals. 

Frequency Sweep Controls 

 Triggering is disabled in this mode. 

 The first data item on the first measurement line below the grid shows the start frequency of the 

sweep. 

 Cursor measurements on second line below the grid will be switched to the frequency measurement 

mode. 

 

 

 

 

 

 

 

 

 

1. Sweep start frequency. 

2. Sweep stop frequency. 

3. Scroll bar to adjust sweep start frequency. 

4. Scroll bar to adjust sweep stop frequency. 

Pulse Generator Controls 
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1. Pulse width / repetition period. 

2. Buttons for selecting pulse width / repetion range. 

3. Scroll bar to adjust pulse width. 

4. Scroll bar to adjust pulse repetition period. 

5. Ratio of pulse width to period, expressed as a percentage. 

6. The pulse repetition frequency. 

Double click on the items 5 or 6 to open the Generator Settings window. 

Arbitrary Waveform Generator (AWG) Controls 

 

 

 

 

 

 

 

 

 

See Appendix for Arbitrary Wave Generator Script Commands 

1. Waveform period defined in the script. Double click on digits to reload script value. 

2. Scroll bar for fine adjustment of the period. 

3. Scroll bar for coarse adjustment of the period. 

4. The name of the downloaded script file. Double click on name to open file dialog. 

5. Chooser to select a mark for D1. 

6. The output level as a percentage of the level defined in the script. Double click to reload the script value. 

7. Script execution indicator. 

 Bright blue: script commands running. 

 Blue: script executed wait command. 

 No color - script is stopped or is not running. 

8. Script start button [RUN]. Momentary press to run script. 
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Generator Settings 

Open with: Menu-> Options-> Generator Settings. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Auxilliary Outputs 

1. Check box to invert auxiliary output signal. Unchecked is normal, checked is inverted. 

2. Chooser for selecting the source for the auxiliary output. Choose one of the following: 

 LOG 0 0 V. 

 LOG 1 3.3 V. 

 TRIG. OUT Trigger signal. 

 PULSE GEN. Pulse generator. 

 AWG GEN. Arbitrary waveform generator. 

 NOISE Noise generator. 

 100 MHz System clock frequency. 

 D1 INPUT  Digital signal input at D1. 

Virtual Generator Channel Settings 

3. Scroll bar to adjust time matching of generator virtual channel (A2) to real channel (A1). The matching is 
carried out inside the FPGA chip with digital delay lines and phase shifters. 

4. Scroll bar to set the effective generator output load (zero to infinity). 

5. Button for quick setting of load to 50 Ohms. 

6. Check box to set sin (x)/x correction. 

 Unchecked Always off. 

 Grayed  Automatic depending on the operating mode (recommended). 

 Checked  Always on. 

Modulation Settings 

7. Buttons to select the modulation type. Unpressed is not selected, pressed is one of: Amplitude [AM], 
Frequency [FM], Phase [PM] and Summation [SUM]. 

8. Buttons to select the modulation signal source. Unpressed is not selected, pressed is one of: A1, A2, 
D1 ... D4, Internal, Pulse and AWG. 
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9. Check box to invert the modulating signal. Unchecked is normal, checked is inverted. 

10. Buttons to select frequency band (upper frequency) for internal modulation source. Unpressed is not 
selected, pressed is one of: 10k, 100k, 1M, 10M, 100M. 

11. Button to select noise generator as the modulation source. Unpressed is not selected, pressed is 
selected. 

12. Buttons to select the modulating signal waveform. Unpressed is not selected, pressed is one of: Sine, 
Square, Triangle, Forward slope sawtooth or Downslope dawtooth. 

13. Scroll bar for coarse adjustment of the modulating frequency within the set band. 

14. Scroll bar for fine adjustment of the modulating frequency within the set band. 

15. Buttons to select the FM deviation range. Unpressed is not selected, pressed is one of 2k / 20k on A1 or 
10k / 100k on other channels. Greyed if FM mode not selected. 

16. Scroll bar to adjust the modulation depth depending on chosen modulation type. 

 AM coeficient (% or %/Div) 

 FM deviation (Hz or Hz/Div) 

 PM index (x90 Grad or x90 Grad/Div.) 

 Sum level (% or %/Div). 

Generator Parameter Input Keypad 

Provides an on-screen keypad to input generator frequency and signal level parameters. 

To open for frequency settings: double left click on the current generator frequency (large digits on the 
generator control panel). 

To open for level settings Vpp: double left click on the current generator voltage (large digits on the 
generator control panel). 

To open for level setting Vrms (as shown in screenshot) or dBm: double left click on the current generator 
level (small digits to left of Vpp digits on the generator control panel when in the relevant mode). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The keypad allows the following generator settings to be made: 

 Frequency (Function and Mod. modes) 

 Start / Stop frequencies (Swp mode) 

 Output level (all modes) 

Digits can be edited using the keypad buttons or by PC keyboard entry. 

Button [<] deletes last digit. 

Buttons ["units"] (eg [mVrms] and [Vrms] in this example) set the parameter to the required value and unit 
and closes the window. 

Closing the window with [X] or [Cancel] keeps previous setting 
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Advanced Settings 

Open with: Menu-> Options-> Advanced Settings or Ctrl + X. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Scroll bar to time align the analog and digital channels. Alignment is carried out inside the FPGA via digital 
delay lines. 

2. Entry box for setting the required velocity factor (as a percentage) for the reflectometer measurement. Box 
displays current setting. 

3. Check box to enable distance measurement using double cursors, taking into account the set velocity 
factor. Unchecked is disabled, checked is enabled. 

4. Scroll bars to adjust the user defined attenuation / gain compensation for external probes or attenuators. 
All values, graphs, cursors and automatic measurements in all modes are recalculated accordingly. To select 
the required probe setting for A1 channel use Menu-> Options-> Probe A1 and check required value. 

5. Scroll bar to adjust the user defined value of Zo for the antenna analyzer mode. To select the required Zo 
setting use Menu-> Tools-> AA Settings-> Zo and check required value. 

6. Check box to enable / disable comma delimiter when exporting CSV files. Unchecked is disabled, checked 
is enabled. 

7. Check box to enable / disable automatic level tracking marker in FRA and AA modes. Unchecked is 
disabled, checked is enabled. 

8. Check box to set the DSP filter window in FRA and AA modes. Unchecked, the window is a time domain 
rectangular window. Checked, the window is Blackman-Nutall which improves noise immunity but decreases 
the low end dynamic range slightly (2..3 dB raised noise floor).  It is recommended to check this box when 
max dynamic range is not needed. 

9. Check box to enable / disable the generator level display in dBm (50 Ohm load). Unchecked, the display is 
in Vrms (level shown depends on high resistance or 50 Ohm load setting in item below). Checked, the 
display is in dBm (50 Ohm load) independent of item 10 setting. 

10. Check box to enable / disable the displayed generator level (Vpp or Vrms) assuming a 50 Ohm load. 
Unchecked, the level is displayed assuming high resistance load. Checked, the level is displayed assuming 
a 50 Ohm load. 

11. Check box to enable / disable module type has no mode setting jumpers. Uncheck for module with 
jumpers, check for module without jumpers. 
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12. Check box to enable / disable the extended 2.5 GHz frequency range of the combined multi-frequency 
FFT. Unchecked is disabled, checked is enabled. 

13. Chooser for selecting an external frequency multiplier or enabling the operation with external modules 
with ADF4351, MAX2870, MAX2871 chips. 

14. Check box to enable / disable a receive frequency offset in FRA mode. Unchecked is disabled, checked 
is enabled. 

15. Entry box to edit the required receive frequency offset or fixed frequency of the detector in FRA mode. 
Box displays current setting. Value enabled by checking item 14 above. Greyed if item 14 above is 
unchecked. 

16. Check box to enable / disable fixed receive frequency of the detector for the FRA mode (selects the IF 
value for operation in conjunction with external modules with two ADC4351, ADF4351, MAX2870, MAX2871 
chips and a mixer). Unchecked is disabled, checked is enabled. Greyed if item 14 above is unchecked. 

17. Check box to enable / disable asynchronous Fs in FRA mode. Unchecked is disabled, checked is 
enabled. It is recommended to enable whenever there is no need for information about the phase of the 
signal. 

18. Chooser for selecting the asynchronous Fs in FRA mode. Recommended value is 2. Greyed if item 17 
above unchecked. 

19. Check box to enable / disable a second ADF4351, MAX2870, MAX2871 (LO). Unchecked is disabled, 
checked is enabled. 

20. Chooser for selecting the output level of the second ADF4351, MAX2870, MAX2871 (LO). 

21. Check box to enable / disable the local oscillator frequency offset relative to the generator (selection of 
the IF value for operation in conjunction with an external module with two ADF4351, MAX2870, MAX2871 
chips and a mixer). Unchecked is disabled, checked is enabled.. 

22. Entry box to edit the frequency offset or fixed frequency of the LO (value in kHz). Greyed if item 21 above 
unchecked. 

23. Check box to enable / disable fixed LO frequency. Unchecked is disabled, checked is enabled. Greyed if 
item 21 above unchecked. 

23. Check box to enable / disable the PLL PFD frequency to 20 MHz. Unchecked is disabled, checked is 
enabled. Reduces the level of phase noise and the time of locking the PLL loop. The frequency step in this 
mode is increased from 1 to 5 kHz. It is recommended to enable when the minimum step is not needed. 

Items 13, 16 and 19 ... 24 above are designed to work with additional external modules for expanding the 
frequency and phase response analyzer and antenna analyzer (for more details, see FRA and AA modes). 
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Serial Decoder 

For successful decoding, the oscilloscope sampling rate must be at least 4 times the bit rate. For the 
maximum amount of decoded data, the oscilloscope sampling rate should not exceed the bit rate more by 
more than 10 times. 

Decoder Traces in Main Window 

When the decoder is enabled (see settings below), traces are added to the screen showing the decoded 
data. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Decoded data RXD. 

2. Decoded data TXD. 

Serial Decoder Settings Window 

Open with: Menu-> Tools-> Serial Decoder or Ctrl + F2. 
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1. Chooser to select the type of decoder or off (current software version supports only RS232 (RS422, 
RS485)). 

2. Entry box for setting the data rate data rate. 

 Up to 50 MBaud for analog channels. 

 400 MBaud digital channels. 

3. Chooser to select the parity bit as one of. 

 None. 

 Even. 

 Odd. 

 Ignore (any value accepted). 

4. Entry box to set the number of data bits (2 ... 32). 

5. Chooser to select the bit sequence (for RS232 standard LSB First). 

6. Entry box to set the number of stop bits (1 ... 2). 

7. Chooser to select the RXD channel source for decoding. 

8. Chooser to select the TXD channel source for decoding. 

9. Check box to enable / disable inversion of RXD or TXD signals. Unchecked in non-inverted, checked is 
inverted.When inverted the start bit is high and stop bit is low. 

10. Chooser to select the format of the decoded data display. One of HEX, DECIMAL or ASCII. 

11. Decoded data display window. 

Binary Recorder 

Saves a long term recording of the analog channel A1 to a file in binary format. In addition, a text file (.txt) 
with the same name is saved containing the parameters of the binary file. In peak detector mode, the 
minimum value is written first, then the maximum. 

Works only when in the Scan Mode Display (see Scan Mode Display). 

The data in the file in all digitization modes are recorded in 16 bit signed format. Corresponding to the grid 
boundary values of -32768 to 32,767. 

Recorder window can be minimized with the main window of the program. 

Binary Recorder Settings Window 

Open with: Menu-> File-> Binary Recorder (A1). 
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1. Information about the parameters of the recording file. 

2. Button to open a Windows file dialog to set the required file for recording. 

3. Path and name of the recorded file. 

4. The current size of the recorded data. 

5. Current recording time in days hours: minutes: seconds. 

Buttons to start and stop recording or to exit recorder. 

Frequency Meter 

When enabled, displays in the main window a frequency measurement of the signal on a selected input 
channel. The principle of operation is based on the simultaneous measurement of the frequency and period 
of the signal, which provides constant relative measurement accuracy over a wide frequency range. The 
meter can also be switched to the pulse counting and period measurement mode and can operate with any 
input. 

When working with an analog input channel of the oscilloscope, the meter operates according to the set 
trigger level. In this case, it is possible to adjust the level of noise reduction (hysteresis). 

When working with digital inputs, the meter operates at the set threshold level of the corresponding channel. 

Key features: 

 8 digit frequency display. 

 Measured frequency range for an analog input channel is 1 Hz ... 60 MHz.  

 Measured frequency range for a input digital channel is 1 Hz ... 200 MHz. 

 Measured period is 10 ns ... 21 s (with 5 ns resolution). 

 Count to 4294967295 (2 ^ 32 - 1). 

It is also possible to work from the oscilloscope triggering, which in combination with the additional trigger 
settings T+ provides a powerful tool for analyzing signals. For example: 

 Measure the frequency of data packets follow and count them. 

 To account for bad pulses. 

 Count the number of pulses of a certain duration, etc. 

When the oscilloscope sweep is off of the ([RUN] button un-pressed), the frequency meter display update is 
stopped. In this case, the frequency counter continues to operate (measure the frequency or period, count 
the pulses). When the [RUN] button is pressed the frequency meter display update is resumed. Oscilloscope 
digitization modes, sweep speed, and channel on / off do not affect the operation of the frequency meter. It is 
not possible to use for the frequency meter in the stroboscope mode. 

Frequency Meter Settings Window 

Open with: Menu-> Options-> Freq. Meter. 
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1. Check to turn frequency meter off. 

2. Check to turn frequency meter on. 

3. Check to turn period / pulse counter on. 

Items 1, 2 and 3 are mutually exclusive selections. 

4. Button to reset pulse counter. Alternatively use Ctrl + R to reset. 

5. Check to select required channel for measurement. 

6. Check to measure frequency according to hysteresis between set threshold levels on D3 and D4 
channels. Allows frequency measurement of signals with low slew rate. Signal must be simultaneously 
supplied to both the D3 and D4 inputs. 

7. Check to measure frequency or period of oscilloscope trigger. 

Items 5, 6 and 7 are mutually exclusive selections. 

See also Trigger Module Auto Measurement and Advanced algorithm for accurate measurements of the 
peak level and frequency in Spectrum Analyzer mode. 

Spectrum Analyzer 

The spectrum analyzer uses FFT calculations to monitor signals in the frequency domain. 

Weak Signals Measurement 

The circuit design, PCB layout and the subtractive Dither technique provides a "clean" spectrum of intrinsic 
noise, free from parasitic (internal) spectral components. This allows detection and measurement of small 
signals of tens of microvolts (Vrms). 

Combined Multi-Frequency FFT 

The combined multi-frequency FFT is used to observe and measure high-frequency signals. It removes the 
restriction in the range of the first Nyquist zone (half of the sampling frequency). It determines the Nyquist 
zone of all the spectral components of the signal and suppress interfering signals in the non-working zones 
(spectral inversion). This method is applicable provided that the spectrum of the observed signal is a finite 
set of relatively narrow band of spectral components, i.e. there are no noise-like, broadband (wider than a 
few MHz) signals in the spectrum. 

 Turned on simultaneously with the oscilloscope strobe mode. 

 Allows observation and measurement of signals in the band up to 400 MHz (oscilloscope bandwidth) 

without Spectral inversion. 

 Allows signal detection up to hundreds of MHz. 

 Generates a spectrogram with 1 GHz bandwidth and a frequency resolution of 10 kHz containing 

163,840 points. 

The combined FFT mode does not work with the virtual analog channel. It always uses a Flat Top FFT 
window function and Auto mode to the number of points for the FFT calculation. 

Advanced Algorithm For Accurate Measurements Of Peak Level and Frequency 

An advanced algorithm is used for the FFT automatic measurements. It allows the frequency and level of the 
main spectral peak to be measured with high accuracy (better than the step between the FFT bins, and 
better than the simple maximum bin level). 

The algorithm is based on a weighted averaging of bins in the vicinity of the frequency maximum, taking into 
account the noise bandwidth of the selected window. 

For best results, it is recommended to set the maximum number of oscilloscope samples and to enable Auto 
mode for the number of FFT points. Set the FFT window to one of: Blackman, Blackman-Harris, Nutall or 
Blackman-Nutall, and enable spectrogram averaging mode. 

 

The accuracy of the frequency measurement may increase by an order or more (depending on the signal / 
noise ratio of the signal). This algorithm may in some cases be a good alternative to the Frequency Meter, 
and (in conjunction with the Combined Multi-Frequency FFT) can accurately measure frequencies of up to 
hundreds of MHz. 
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Spectrum Analyzer Display Window 

Enable with: Menu-> Tools-> Spectrum Analyzer (FFT A1) or F4. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Scale level at the top grid line (maximum input level). 

2. Input channel for FFT. 

3. The number of FFT points. 

4. Frequency range of the spectrogram (equal to half the sampling frequency signal in the time domain). 

5. Horizontal zoom figure. No value shown for x1. 

6. The vertical scale (dB/Div). 

7. The spectrogram start frequency (corresponds to the left edge of the grid). 

8. Cursor frequency measurements (if enabled Menu-> View-> Double Cursors). 

9. Automatic and cursor amplitude measurements. (if enabled Menu-> View-> View-> Measure (Ctrl + M) 
and Menu->View-> Double Cursors). From left to right: 

 The frequency of the main peak. 

 The set and current number of averages. 

 The level of the main peak. 

10. Extra Information (Not shown is above screen shot). Menu->View-> View-> Extra Info and with no 
cursors or single cursors. Gives a display of the following information at the top of the display grid from left to 
right. 

 Type of FFT window weghting. 

 Noise power bandwidth (NPBW) of the FFT bin. 

 10 * lg (NPBW). 

 Processing gain of the FFT. 

In double cursor mode additional measurements. From left to right. 

 P, the integrated signal power between vertical cursors. 

 The spectral density of the signal power between vertical markers. 

 Pn, the ratio of the integrated signal power between vertical cursors and the level of the main peak. 

Allows phase noise measurement. 

 Offset is the distance in frequency between the main peak and the average of frequencies of vertical 

cursors. 

See also Spectrum Analyzer in FRA Mode. 
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FFT Settings Window 

Open with: Menu->Tools-> FFT Settings or Ctrl + F4. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Buttons to select the required number of FFT points. Auto button selects the maximum for the current 
number of samples. 

2. Buttons to select the required FFT window function. 

3. Buttons to select the required vertical scale measurement units with different impedances.  

4. Check box to enable / disable 15 dB/Div vertical zoom. Unchecked is 10 dB/Div (default), checked is 
enabled.  

5. Buttons to select the required number of spectrograms for the moving average. 

6. Check box to enable / disable a moving average spectrogram. Unchecked is disabled, checked to 
enabled. 

7. Buttons to select the required horizontal zoom (also the mouse wheel can be used while pointing to the 
area of interest). 

8. Check box to enable / disable simultaneous display the time domain signal. Unchecked is disabled, 
checked to enabled. 

9. Check box to enable / disable simultaneous FFT calculation for two channels. Unchecked is disabled, 
checked to enabled. Allows measurement of phase relationships at maximum frequencies (with averaging 
off). 

10. Check box to enable / disable the display of power (Watts) for cursors and automatic measurements. 
Unchecked is disabled, checked to enabled. 
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LC Meter 

Tool for measuring inductance and capacitance. 

LC Meter Ranges: 

 Inductance:  50 nH ... 3 H 

 Capacitance:  0.5 pF ... 30,000 µF 

 ESR (C> 0.5 uF):  50 mOhm ... 1kOhm 

The measurement algorithm is based on measuring the complex impedance of the connected circuit using 
the shunt-thru method. Measurements are taken at fixed frequencies over a wide range. The type of 
reactance the DUT is determined automatically. When measuring capacitance of less than 100 pF it is 
recommended to enable the small capacitance measuring mode (see Mode Selection). Calibration is 
necessary after changing the mode. 

The meter uses a simplified and rapid open calibration procedure using the [Calibrate] button while the test 
connecting wires are open. The accuracy in measuring small inductance values depends on the type of 
connector and the connection method to the item under test. It is recommended to connect the DUT using 
wires of minimum length. When measuring small inductance value it is recommended to be measure and 
then subtract the self-inductance of the connectors and connecting wires. 

It is possible to use the cursor measurements in the Antenna Analyzer mode (after OSL calibration) for more 
accurate measurement of small values of inductance or capacitance (see Vector Antenna Analyzer). 

When measuring the ESR value of high quality electrolytic or polymer capacitors, it is necessary to have 
reliable low resistance connections with minimum length. In this case, estimated ESR measurements <50 
milliohms are possible. 

Important! Discharge capacitors before connecting to meter. The generator output 
cannot tolerate reverse voltage. Connecting a high voltage charged capacitor can 
damage the module. 

LC Meter Window 

Open with: Menu-> Tools-> LC Meter of F3  

Note: the LC Meter requires specific mode jumper settings (see Mode Switch). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Spot frequency measurement results (rough estimate). 

2. Calculated measurement result. 
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Frequency Response Analyzer 

The FRA uses a frequency sweep generator with a synchronous tracking digital quadrature receiver. 
Supports measurement of two port transfer function. The main characteristics are: 

 Measures amplitude and phase characteristics vs frequency. 

 Frequency Range: 100 Hz ... 100 MHz. 

 Dynamic range (10 kHz ... 60 MHz): > 90 dB. 

 Dynamic range (100 Hz ... 100 MHz): > 75 dB. 

 Customizable linear and logarithmic scales. 

 Calibration (amplitude and phase normalization). 

Frequency Response Analyzer Display Window 

Enable with: Menu-> Tools-> Freq. Response Analyzer or F5. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. The reference level corresponding to 0 dB (selected via A1 channel sensitivity setting buttons). 

2. The selected frequency range (set using the generator start and stop frequency adjustments, see 
Frequency Sweep Controls). 

3. Signal amplitude scale (in this case, in dB relative to the reference level). 

4. The signal phase scale (degrees). 

5. Cursor measurements for frequency (horizontal scale). 

6. Cursor measurements for amplitude and phase (vertical scale). 

7. Step frequency change (depending on the sweep range of and the set number of samples). 

8. Digital receiver bandwidth (depending on the sweep speed and the number of samples). 

9. The name of the calibration file. 
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Frequency Response Settings Window 

Open with: Menu-> Tools-> FRA Settings 

 

 

 

 

 

 

 

 

 

 

 

1. Check box to enable / disable amplitude scale values. Unchecked is disabled, checked is enabled. 

2. Check box to enable / disable VSWR scale and measurement when using an external RF measuring 
bridge (when the main scale has the sense of Return Loss). Unchecked is disabled, checked is enabled. 

3. Check box to enable / disable phase scale and measurement. Unchecked is disabled, checked is enabled. 

4. Button [Calibration...] to open the calibration window. See Calibration (amplitude and phase normalization) 
below. 

5. Chooser to select the Amplitude Range. Check to select one of the dB/Div values or Linear scale. 

Default FRA Settings 

When FRA mode is selected, some of the generator and oscilloscope panel controls are unavailable 
(greyed), and some are set to default values which may be later adjusted. 

 Generator output 0 dBm, that is: 1.265 Vpp or 447 mVrms with no load and 224 mVrms with 50 Ohm 

load. (adjustable). 

 Generator mode set to sweep (can be turned off for zero span mode). 

 Generator waveform set to sine wave (fixed). 

 Number of samples set to 1000 (adjustable). 

 Channel sensitivity set to 0.1 V/Div to obtain the reference level 0 dBm. (adjustable) 

 External probe division ratio set to x1 (adjustable) 

 Passband limiting set to off (fixed). 

 Input type set to AC coupled (fixed). 

 Triggering set to off (fixed). 

 Sweep speed set to 0.2 s/Div (adjustable but sweep speed of 0.2ms/Div and faster are unavailable). 

Calibration (Amplitude And Phase Normalization) 

Connection For Calibration 

 Connect a cable with impedance of 50 ohms to the input of the oscilloscope. 

 Connect a cable with characteristic impedance of 50 ohms to the generator output. 

 Connect the two cables together via a coax-coax connector. 

 Calibrate. 

 Replace the coax-coax connector with the DUT. 
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FRA Calibration Window 

Open with: Tools-> FRA Settings-> Calibration or Ctrl + F5. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Button to start calibration (Calibration takes about 15 seconds). 

2. Entry box to set the calibration reference level (default 0 dB). 

3. Progress bar during calibration. 

4. Button to save the calibration file to the PC hard disk (calibration must be saved for use). 

5. Check box to use a calibration file. Unchecked is don't use, checked is use. 

6. Button to load a saved calibration file. 

7. Parameter values with which the calibration is performed. 

Calibration is performed in the frequency range 10 kHz ...100 MHz with 1000 points. The calibration step is 
100 kHz (interpolation is applied for intermediate values). When using the external frequency multiplier, the 
data values will be different. 

The default calibration file extension is .pvc. 

Changing The Sweep Speed And Number Of Samples 

The receiver's bandwidth (see the 4th row under the grid - RBW) and, therefore, the resulting processing 
gain and dynamic range (noise track level) depend on the choice of the sweep speed and the number of 
samples. Reducing the scan speed and / or number of samples will allow measurements with a high 
dynamic range. At low (audio) frequencies, it is recommended to enable the FRA, AA Filter (see Advanced 
Settings) and ensure that the receiver bandwidth (RBW) is several times lower than the initial viewing 
frequency. 

Changing The Level of Generator Output And Reference Level 

It is acceptable to select other generator output level values as well as the sensitivity (reference level) of the 
analog channels (other than the default values). The following should be taken into account: 

 When changing the generator output level and / or reference level after calibration the measurement 

accuracy may degrade (calibration violation). 

 When setting a high-level output of the generator (>500 mVrms) may reduce the dynamic range at 

high frequencies (due to the finite internal insulation). 

 For a correct measurement of the absolute voltage values and to obtain the maximum dynamic 

range select the output level of the generator equal to the selected reference level. 

FRA As Spectrum Analyzer 

The digital tunable receiver makes it possible to use the FRA as a spectrum analyzer. In this use, it is 
recommended to disable calibration (since the unevenness of the frequency response and phase response 
of the generator, rather than the analog input, is calibrated to a greater degree). 

It is also necessary to turn on the FRA, AA filter (see Advanced settings) in order to provide high 
suppression beyond the passband. 
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Changing the number of samples and the scanning speed adjusts the receiver bandwidth (see the 4th row 
under the grid - RBW). 

When choosing a bandwidth, it is necessary to ensure that the frequency step (see the 4th row under the 
grid - Fstep) is less than the bandwidth (RBW), otherwise there is a probability of missing spectral 
components. 

Vector Antenna Analyzer 

The Vector Antenna Analyzer uses a frequency sweep generator with a synchronous tracking digital 
quadrature receiver. The analyzer measures the complex impedance of a DUT by the shunt-thru method. 

Features of the AA: 

 Frequency Range:  10 kHz ... 100 MHz. 

 OSL calibration and "mathematical subtraction" of connecting cable. 

 Measurement (calculation) of SWR and Return Loss for cables (lines) with Zo = 10 ... 320 Ohms. 

 Calculating and plotting:  SWR, Return Loss, Q, Rs, Xs, | Z |, Phase Z, Rp, Xp. 

Antenna Analyzer Display Window 

Enable with: Menu-> Tools-> Antenna Analyzer or F6. 

Note the AA requires specific mode jumper settings (see: Mode Switch). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. The maximum signal level before overload (selected using V/Div sensitivity setting buttons). 

2. The sweep frequency span (according to the generator start and stop frequency settings, see Frequency 
Sweep Controls).. 

3. The scale of the first trace. 

4. The scales of the second and the third trace. 

5. Cursor frequency measurements (horizontal axis). 

6. Cursor amplitude and phase measurements (vertical axis). 

7. Frequency step. Depends on the sweep range and the set number of samples). 

8. Digital band pass filter of the receiver. Depends on the sweep speed and the set number of samples). 

9. The name of the calibration file. 
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Antenna Analyzer Settings Window 

Open with: Menu-> Tools-> AA Settings. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Chooser to select the impedance Zo. 

2. Chooser to select the scale range for SWR. 

3. Chooser to select the scale range for impedance. 

4. Chooser to select the scale range Q. 

5. Chooser to select the type of display for the first graph. Shows current setting (Q) 

6. Chooser to select the type of display for the second graph. Shows current setting (|Z|) 

7. Chooser to select the type of display for the first graph. Shows current setting (Xs) 

8. Check box to turn the main display into a Smith chart. Unchecked is normal AA window, checked is Smith 
chart. Alternatively use Ctrl + K to toggle Smith chart on / off. 

9. Button to open the OSL calibration window. Alternatively use Ctrl + F6 to open. 

Antenna Analyzer Auto Setting 

Some controls on the panel of the generator and the oscilloscope will not be available, and some are set in a 
default state. 

 Voltage generator 566 mVpp = 200 mVrms (no load). 

 Generator mode - sweep. 

 Form oscillator signal - sinus (not editable). 

 Number of samples - 1000. 

 Channel Sensitivity 0.1 V / division (maximum 0.8 Vpp input signal). 

 Division factor external probe x1 (not editable). 

 Passband limitation - off (not editable). 

 Input Type - closed (not editable). 

 Triggering - off (can not be edited). 

 Sweep speed - 0.2 s / div (adjustable but sweep speed of 0.2ms/Div and faster are unavailable). 

Open/Short/Load (OSL) Calibration 

Open the calibration window with: Menu-> Tools-> AA Settings-> OSL Calibration or Ctrl + F6. 
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1. Button to start the calibration with open calibration standard. 

2. Button to start the calibration with short calibration standard. 

3. Button to start the calibration with 50 Ohm calibration standard. 

4. Progress indicator during calibration. 

5. Button to save calibration file on the PC hard drive (calibration must be saved for use). 

6. Button to load a calibration file (opens file dialog). 

7. Check box to enable use of calibration. Label shows current file name. Unchecked is do not use, checked 
is use. 

8. Parameters with which the calibration is performed. 

Calibration is always made in the frequency range 10 kHz ... 100 MHz, 1000 points. Calibration Step 100 
kHz and to produce intermediate values of the calibration applies interpolation. When using the external 
frequency multipliers, the data values will be different. 

The default calibration file extension is .pvo. 

Changing The Scanning Speed And Number Of Samples 

The receiver's bandwidth (see the 4th row under the grid - RBW) and, therefore, the resulting processing 
gain and dynamic range depend on the choice of the scanning speed and the number of samples. 

The default values provide suitable parameters for most cases (the dynamic range of the receiver is >80 dB). 

It is recommended to reduce the scanning speed for large number of samples or for low frequency (<10 kHz) 
measurements. 

Changing The Oscillator Output Level And The Input Sensitivity 

It is possible to select other generator output level values as well as the analog channel sensitivity (different 
from the default values). It is necessary to carry out OSL calibration again after the change. 

Achieving Maximum Measurement Accuracy 

When measuring low VSWR (eg Return Loss <-40 dB, values of capacitance < 1 pF, and the like) it is 
recommended to do the following for best accuracy: 

 Ensure a secure connection of the USB cable by checking the primary power supply voltage (see. 

Menu-> View-> View-> Extra Info). 

 Put the module and software into the Antenna Analyzer mode. 

 Set the required range for the frequency sweep and turn on the generator. 

 Allow the unit to warm up for a few minutes. 

 Perform OSL calibration. 

 When conducting the measurements do not increase the scanning speed and periodically check 

VSWR readings with a 50 Ohm calibration standard connected and reactance readings with a short 

calibration standard connected. 
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Reflectometer 

The module supports the basic functions of a time domain reflectometer (TDR). See Mode Switch to 
configure the module for reflectometer mode. The reflectometer allows cable length measurement, distances 
to impedance irregularities or cable damage and velocity factor. 

 Minimum measured cable length = 2 meters. 

 The minimum duration of the probe pulse = 10 ns. 

 The maximum amplitude of the probe pulse on the matched load = 1.65 V. 

 Velocity factor = 0 … 100% (step 0.1%). 

Taking Measurements 

1. Set the velocity factor and turn on reflectometer cursor measurements (see Advanced Settings). 

2. Turn on the generator and select pulse mode. 

3. Set the desired amplitude, duration, pulse repetition period and the scanning speed. When testing a 
mismatched cable, the pulse repetition period must be set to at least 10x the margin for the for the expected 
cable length. This will eliminate the overlap of multiple reflections from the ends of the cable. 

4. Set the required analog channel sensitivity (vertically scale). It’s acceptable for the probe pulse to 
overdrive the oscilloscope input voltage range. In addition, for triggering and cursor measurements, it is 
recommended to use the generator virtual analog channel. 

5. Enable and configure the triggering by the probe pulses. It is recommended to set the pre-trigger length to 
1 Div. In some cases it is convenient to use the generator virtual analog channel for triggering. 

6. Take measurements using double cursors. 
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Calibration 

Zero Calibration 

When changing the voltage level or USB cable or with a big change in the ambient temperature, it may be 
necessary to perform zero calibration. 

 Set the mode switch J1 to 1-2 (see: Mode Switch). 

 Unplug everything from the analog input channel. 

 For maximum accuracy, it is recommended to use the averaging mode (Hi Res), a sweep of 5 

ms/Div and a sensitivity of 5 mV/Div. 

 Open calibration window with: Menu-> Options-> Zero Calibration or Ctrl + Z. 

 Use the scroll bar to match the set zero level with the actual level (based on Vdc auto-

measurement). 

Calibration values are stored in non-volatile memory. 

Calibrating The System Clock Frequency 

Open with: Menu-> Options-> System Freq. Calibration.  

Calibrates the system clock generator frequency. 

Simultaneously calibrates: 

 Oscilloscope sweep speed. 

 Generator frequency (all modes). 

 Frequency meter. 

When calibrating against an external reference oscillator, it is useful to use readings from the Frequency 
meter. When calibrating with an external frequency counter, it is recommended to use the pulse generator 
mode. 

Opening and Saving Files 

Data Files 

To open files use: Menu-> File-> Open. 

To save files use: Menu-> File-> Save As. 

Brings up Windows file dialog. Files have the extension .pvd.  

Allows save and restore of all captured oscillograms, spectrograms, FRA graphs, AA graphs, frequency 
meter reading, all auto-measurements, etc. When saving and opening a data file, the associated 
configuration file of the same name (.pvs) is also saved and opened. 

Configuration Files 

To open files use: Menu-> File-> Open Settings. 

To save files use: Menu-> File-> Save Settings As. 

Brings up Windows file dialog. Files have the extension .pvs.  

Allows save and restore of the state of all program controls except for: 

 Interface language. 

 Color settings. 

 System frequency calibration. 

 Time matching of virtual and real-time channels. 

 Time matching of digital and analog time channels. 

 Waveform limit control per second. 

 Custom attenuation / gain settings for external probes or attenuators. 

 Customization of Zo values for AA. 

 Export settings of CSV format. 

 Enabling the persistence mode. 

 Enabling of compact view. 

 Enabling of always on top mode. 
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 Sweep start button. 

 Generator on button. 

Script Files For AWG 

Open with: Menu-> File-> Open AWG File.  

Opens, compiles and loads arbitrary waveform generator file. The file has an extension of .pvg. The program 
has a mechanism to automatically reload and restart file when its contents are changed. This mechanism 
allows quick change of the signals at the output of the generator changing and saving the text of the script in 
a text editor. In the folder of the executable program a pvg.lst file is created containing detailed information 
about the compilation script (Listing File). 

Drag and Drop PVD, PVS, PVG Files 

Data, generator settings and AWG files are supported by Drag and Drop in the window. Also, when setting 
up the operating system extensions association with the program, it is possible to open these files by double-
clicking. 

Export Image (Screen Shot Saver) 

Activate using: Menu-> File-> Export-> Image. 

Brings up Windows file dialog to allow the current viewing area to be saved in the PNG format. It is also 
possible to save the image in BMP format. To do this, manually add the .bmp extension to the file name. 

Export Text File 

Activate using: Menu-> File-> Export-> Text. Supported only for oscilloscope mode. 

Brings up Windows file dialog to export all active and data-containing oscilloscope channels in text format. 
Text is formatted as a table with the numbers of samples and the corresponding voltage values. 

Export CSV File 

Activate using: Menu-> File-> Export-> CSV. Supported only for FRA and AA modes  

Brings up Windows file dialog to export data in CSV format (Comma Separated Values). 

Export Binary File 

Activate using: Menu-> File-> Export-> Row Binary. Supported only for oscilloscope mode. 

Brings up Windows file dialog to export a selected oscilloscope channel in a binary format.  

The export format for analog channels is similar to the format of the binary recorder (see: Binary Recorder). 
For digital channels, a logical zero code is 0x0000 and logical one code is 0x0100. In addition, a text file with 
the same name and extension .txt is saved containing the recorded parameters of the binary file. In peak 
detector mode, the minimum value is written first and then the maximum value. 

Customize Colors and Language 

Open color setting window with: Menu-> Options-> Colors or Ctrl + J. 

Open language setting window with: Menu-> Options-> Language. 
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Shortcut Keys 

Quick Access To Menus 

Ctrl + O   opens the data file. 

Ctrl + S   save the data file. 

Ctrl + T   opens the advanced synchronization settings. 

Ctrl + G   opens the advanced generator settings. 

Ctrl + X   opens the advanced settings window. 

Ctrl + P   toggles peak detector mode on / off. 

Ctrl + A   toggles averaging mode (Hi Res) on / off. 

Ctrl + R   reset frequency counter. 

Ctrl + Z   opens zero level calibration window. 

Ctrl + 1   toggles display channel A1 on / off. 

Ctrl + 2   toggles display channel A2 on / off. 

1    toggles display channel D1 on / off. 

2    toggles display channel D2 on / off. 

3    toggles display channel D3 on / off. 

4    toggles display channel D4 on / off. 

Ctrl + M   toggles display Auto-measure on / off. 

Ctrl + Y   toggles display of digitizing parameters on / off. 

Ctrl + I    toggles display of additional information on / off. 

Ctrl + E   toggles automatic trigger measurement display on / off 

Ctrl + B   swaps current and the background waveform. 

Ctrl + H   toggles persistence mode on / off. 

Ctrl + L   toggles "ribbon" display mode on / off. 

Ctrl + Q   toggles compact mode on / off. 

F1    opens the protocol decoder box. 

F2    opens LC meter window. 

F3    toggles spectrum analyzer mode (FFT) on / off (see also: Ctrl + F, F). 

Ctrl + F4   open the FFT settings. 

F5    toggles FRA mode on / off. 

Ctrl + F5   opens the FRA calibration window. 

F6    toggles  AA mode on / off. 

Ctrl + K   toggles Smith Chart display on / off. 

Ctrl + F6   opens AA OSL calibration window. 

F1    opens the help file. 

Generator 

Ctrl + Spacebar   toggles the generator on / off. 

F7     toggles FRA frequency expansion for MAX2871 on / off. 

F8     setting the start frequency for the sweep. 

F9     setting the stop frequency for the sweep. 

F11     setting amplitude as Vrms or dBm. 

F12     setting amplitude as Vpp. 

Ctrl + U    toggles generator level display as Vrms / dBm. 

Oscilloscope 

Spacebar    start/stop scanning. [Start] button. 

Enter     start/stop a single sweep. [Play] button 

Left / right arrows    set the sweep speed. 
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Up / down arrows    set the A1 channel sensitivity. 

Shift + up / down arrows   set the A2 channel sensitivity. 

Shift + left / right arrows   adjust the horizontal viewing position. 

Spectrum Analyzer (FFT) 

Ctrl + F    toggle spectrum analyzer (FFT) mode on / off. 

F     switch on spectrum analyzer (FFT) mode and switch between channels. 

Ctrl + N    toggles spectrograms averaging on / off. 

N     change in the number averaged spectrograms. 

Ctrl + W    toggles power display on / off. 

Ctrl + V    toggles FFT calculation for two channels (A1 and A2) on / off. 

Ctrl + D    toggles vertical scale 10 / 15 dB / div. 

Ctrl + arrow left / right   adjust display horizontal zoom. 

Frequency / Phase Response Analyzer and Antenna Analyzer 

Up / down arrows   change range (scale) of the first graph. 

Ctrl + Up / down arrows   change range (scale) of the second and third graph for AA. 

Ctrl + arrow left / right    adjust display horizontal zoom. 

 

Mutually Exclusive Functions 

Sync does not turn on (power button is not active). One of the following modes is enabled: 

 
Frequency sweep mode generator in synch with the 
sweep. 

 Frequency / phase meter. 

 Antenna analyzer mode. 

Generator virtual channel not displayed. Strobe mode enabled. 

Scroll display mode not working. 
Frequency sweep in synch with the oscilloscope sweep is 
on. 

Generates only sine wave (other forms not 
present). 10 M or 100 M frequency range selected (button pressed). 

20,000 samples is set and FFT is in Auto mode 
but FFT calculated only over 2048 samples. 

Digital channels with sampling frequency of 1.6 GHz are 
turned on (so the number of analog samples for FFT is 8 
times less). 

Peak detector mode or averaging (Hi Res) not 
activated. 

Fast sweep is turned on, the sampling frequency is 
maximum (200 MHz) so these modes lose their meaning. 

The final frequency of the oscilloscope 
synchronous frequency sweep of the generator 
looks incorrect on the display. 

Fast sweep is turned on and the signal takes more than 
10 divisions. "Scroll" horizontally to the end of the display. 

RS232 protocol decoder not working. No decoded 
data displayed. 

The sampling rate is too low (<4 * Baud Rate) or too large 
(the entire scan is less than the duration of one decoded 
byte). Change the sweep speed. 

When triggering activated, signal is not 
synchronized. 

Incorrect source, level, or trigger hysteresis setting. 
Accidentally pressed button [T+] to enable additional 
trigger modes. 

Strobe mode does not turn on (the power button is 
not active). 

Frequency sweep in synch with the oscilloscope sweep is 
on. 
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Technical Features 

Multi-channel oscilloscope 

General 

Number of analog channels: 1 

Number of digital channels: 4  

Generator virtual analog channel. 

Analog channel bandwidth: 1 Hz ... 400 MHz. 

Max analog channel sampling rate (real time): 200 MHz.  

Max digital channel sampling rate (real time): 1.6 GHz.  

Max sampling frequency (for periodic signals – stroboscope): 10 GHz. 

Analog channel slew rate: 0.9 ns. 

Samples memory: up to 40,000 samples per channel. 

Peak detector mode: 5 ns for analog channel and 625 ps for digital channel (excluding slew rate).  

Averaging mode (Hi Res): up to 16777216 (2 ^ 24) times. 

ADC: 8 Bit (effective up to 16 bits in Hi Res mode and up to 12 bits in a stroboscope mode). 

Analog channel impedance: 50 ohms.  

Digital channel input impedance: 100 kohms || 3.5 pF. 

Analog channel band limited cut-off frequency: 25 MHz.  

Sweep rate: 2 ns / div ...1000 s / div. 

Analog channel sensitivity: 0.1 V / div (up to 5 mV / div in Hi Res and strobe modes). 

Adjustable digital channel trigger threshold: 0 … 13 V (setting accuracy +/- 0.1V + 1%) with 10 mV 
resolution). 

Independent adjustment of a digital channel D4 threshold: 0 ...13 V.  

Adjustment step for time matching of digital and analog channels: 625 ps.  

Maximum allowable input voltage on the analog input channel: 3.5 V. 

Maximum allowable input voltage on the digital channel (DC ... 1 kHz): 100 V. 

Triggering 

Normal and auto modes, on positive or negative slope.  

By the pulse width, period, slope and slew time. 

By pulse number in a series of pulses. 

Takes into account the level of the other channels (logical function).  

According to the video line number PAL, SECAM, NTSC. 

Adjustable hysteresis, noise reduction, dual level. 

Protocol Decoder 

RS232 (RS422, RS485). 

Multifunctional Generator 

General 

Maximum output level at a high-resistance load: 3.3 Vpp. 

DC component: ½ Vpp. 

Output range of the arbitrary waveform generator: 0 … +3.3 V. 

Output impedance: 50 ohms. 

DAC (maximum): 12 bits. 

Function Generator 

Sampling frequency: 400 MHz. 

DDS phase accumulator: 48 bits. 

Frequency range (sinus):  0.001 Hz … 50 MHz (reduced flatness max 100 MHz). 

Frequency range (rectangular, saw, triangle): 0.001 Hz ... 1 MHz.  
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Flatness (0.001 Hz ... 50 MHz):  <0.5 dB. (up to 100 MHz <10 dB) 

Amplitude, frequency, phase modulation / keying, the sum signals, internal and external sources.  

Modulation frequency range: 0.001 Hz ... 100 MHz.  

Capability to modulate by the built-in pulse generator and arbitrary waveform generator.  

Generator frequency sweep can be synched with the oscilloscope sweep. 

Pulse Generator 

Adjustable duty cycle. 

Pulse duration: 5 (10) ns ... 5 s.  

Pulse period: 10 ns ... 5s.  

Output slew rate: 6 ns. 

Under/overshoot: < 3%. 

Arbitrary Waveform Generator 

Waveform scripting language. 

Built-in script compiler. 

15 commands. Command time from 5 ns. 

From simple output values from the memory to cycles, subroutine calls, delays etc. 

Memory for script commands: 2048. 

Auxilliary Digital Output 

Output levels: 0 ... 3.3 V. 

Output impedance: 50 Ohms. 

Configurable as: 

 Synch output 

 Pulse generator output. 

 Arbitrary waveform generator output. 

 Noise generator. 

 System frequency output 

Frequency Meter 

Uses hardware counters for frequency and period (reciprocal counting). 

Analog input uses trigger level with adjustable threshold and hysteresis.  

Digital inputs use their respective set trigger levels. 

Counts or measures the frequency or period of oscilloscope trigger events. 

8 digit frequency display. 

Frequency measurement range for analog input channel:  1 Hz ... 60 MHz.  

Frequency measurement range for digital input channel:  1 Hz ... 200 MHz. 

Period measurement range: 10 ns ... 21 s (with a resolution of 5 ns). 

Pulse counter to: 4294967295 (2 ^ 32 - 1). 

Measurement accuracy referred to system VCTCXO clock:  <1PPM 

Spectrum Analyzer 

General 

Principles of Operation:  FFT and combined FFT. 

Customisable FFT size. 

9 window functions. 

Averaging and scaling.  

Vertical unit selection for circuits with different impedances. 

Algorithm for accurate determination of frequency and maximum amplitude by the method of amplitude 
weighting of neighbouring bins. 
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Combined Multi-Frequency FFT Mode 

Assumes the signal spectrum is a finite set of relatively narrow band components. 

Correct determination of the Nyquist band and suppression of out-of-band spurious signals. 

3dB Frequency range:  up to 400 MHz (without Spectral inversion). 

FFT Size:  up to 163840 points (frequency resolution up to 10 kHz, spectrogram bandwidth:  1 GHz). 

LC Meter 

Measure capacitance and inductance using the shunt-thru method.  

Measurement of electrolytic capacitor ESR. 

Capacitance measurement range:  0.5 pF .. 30,000 uF. 

ESR measurement range (C> 0.5 uF):  50 milliohms … 1kOhm. 

Inductance measurement range:  50 nH ... 3H. 

Frequency Response Analyzer 

Uses sweep and synchronous tracking digital quadrature receiver. 

Four-terminal transfer function measurement. 

Measures amplitude and phase characteristics. 

frequency range:  100 Hz ... 60 MHz (up to 100 MHz with reduced dynamic range) 

Dynamic range (10 kHz ... 60 MHz):  > 90 dB. 

Dynamic range (100 Hz ...100 MHz):  > 75 dB.  

Linear and logarithmic scales with customizable range. 

Calibration (amplitude and phase normalization).  

Ability to work as a spectrum analyzer. 

Vector Antenna Analyzer 

Uses sweep and synchronous tracking digital quadrature receiver. 

Measurement of complex load impedance using the hunt-thru method. 

Frequency range:  10 kHz ... 60 MHz .. (up to 100 MHz with reduced accuracy). 

OSL calibration and "mathematical elimination" of connecting cable. 

Measures VSWR and Return Loss for cable/lines with Zo = 25, 50, 75 or 100 Ohms. 

Calculates and plots:  VSWR, Return Loss, Q, Rs, Xs, | Z |, Phase Z, Rp and Xp. 

Reflectometer 

The module supports the basic functions of a cable reflectometer (TDR). 

Minimum measured cable length:  2 m. 

Minimum duration of the test pulse:  10 ns. 

Maximum amplitude of the test pulse on the matched load:  1.65 V. 

Velocity factor setting range:  0 … 100% (in 0.1% steps). 

General Parameters 

Current consumption from the USB:  < 420 mA. 

Recommended supply voltage: 4.7 ... 5.0 V. 

USB data rate:  up to 3 Mbit/s. 

 

Analog channel typical bandwidth (0.1 V / div. Test voltage = 200 mVrms) 

100 MHz 200 MHz  300MHz 400 MHz 500 MHz 600 MHz 700 MHz 800 MHz 900 MHz 1 GHz 

0 dB -0.4 dB -1.3 dB -2.7 dB -4.6 dB -6.8 dB -9.3 dB -11.6 dB -13.9 dB -17.7 dB 

 

Analog channel intrinsic noise level for different values of sensitivity and different bandwidths. Typical RMS 
voltage (Vrms) with 50 Ohms termination. 
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 400 MHz 25 MHz (BW Limit) 

0.1 V / div 1.85 mV 1.3 mV 

50 mV / Div 1.7 mV 1.2 mV 

20 mV / Div 1.6 mV 1.1 mV 

10 mV / Div 1.6 mV 1.1 mV 

5 mV / Div 1.6 mV 1.1 mV 

 

Typical signal distortion of generator sinusoidal output at different frequencies. Vpp with no load = 2.0 V. DC 
with no load = 1V. Load of 50 Ohms. 

 2nd harmonic (dB) 3rd harmonic (dB) 4th harmonic or worst spur (dB). 

1.03 kHz (600 Ohm load) - 65 - 65 - 70 

103 kHz - 65 - 65 - 70 

1.03 MHz - 60 - 65 - 60 

10.3 MHz - 49 - 54 - 51 

41 MHz - 41 - 49 - 53 

76 MHz - 39 - 50 - 47 

 

Typical signal distortion of generator sinusoidal output at different amplitudes Vpp with no load. F = 10.3 
MHz. Vdc = ½ Vpp. Load of 50 ohms. 

 2nd harmonic (dB) 3rd harmonic (dB) 4th harmonic or worst spur (dB) 

2 V - 49 - 54 - 51 

1 V - 51 - 56 - 52 

100 mV - 41 - 49 - 47 

30 mV - 38 - 49 - 42 

10 mV - 30 - 39 - 33 

3 mV - 34 - 31 - 22 

1 mV - 35 - 10 - 14 

 

Typical levels of generator phase noise (dBc / Hz) at 10.3 MHz and 30.3 MHz for various frequency offsets. 
Vpp with no load = 2.0 V. Vdc with no load = 1V. Load of 50 ohms. 

 3 kHz 30 kHz 300 kHz 3 MHz 

10.3 MHz - 120 - 124 - 119 - 126 

30.3 MHz - 114 - 118 - 112 - 123 

 

 



 

1 

Appendix 

Arbitrary Waveform Generator Script Commands 

Arbitrarily waveform generator file in the simplest case is a text file that lists the values voltages separated by 
a semicolon. Values are given in millivolts from 0 to 4095. The values will appear in succession at the 
generator output. Maximum number of values in the file: 2048. The maximum speed of the output values: 
200MHz. After the withdrawal of the 2048-th value, the first will be output again, then the second, etc. cycle 
repeated. 

To change the values of output speed controls, use the generator control panel, and / or the value set in the 
file using directive #CLOCK N - where N - 200 MHz frequency divider. 

It is possible to output a smaller number of values. To do this, use the command LOOP U - where U - the last 
output value before proceeding with the first. 

 

//============================================================================ 

// Example of a simple file generator to output a1 MHz square wave: 

# CLOCK 100  // Set the clock frequency of 2 MHz (200 MHz / 100). 

0;  // Set the voltage 0 mV. 

LOOP  3300; // Set the voltage to 3300 mV and go to the output of the first value. 

//================================================ ============================ 

 

Text coming after // is a comment and is ignored. For single cycle output use command STOP U - where U - 
the last output value before stopping. After stopping the generator can be started again from the generator 
control panel. 

 

================================================ ============================ 

// Example of a file for outputting 5 rectangular pulses with a duration of 0.1 µs and a pause between them of 
0.1 µs: 

# CLOCK 20  // Set the repetition period of the clock signal = 100 ns. 

3300;  // Set the voltage of 3.3 V. 

0;  // Set the voltage of 0 V. 

3300; 

0; 

3300; 

0; 

3300; 

0; 

3300; 

STOP 0; Set 0V and stop output. 

// =========================================================================== 

 

 

The AWG capabilities are not limited to STOP and LOOP commands. 
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List Of Commands 

Command Pairs Range Function Voltage Runtime (cycles) 

OUT U 0...4095 the output voltage. U mV one 

DIFF dU -4095...4095 voltage change. Change to dU mV one 

STOP U 0...4095 stop. U mV to rep. run. 

LOOP U 0...4095 cycling. U mV one 

DELAY N 0...4095 N cycles delay. without change N 

REPEAT N 0...4095 repeated N times. without change one 

eNDREP dU -4095...4095 end of the repeat unit. change to dU mV one 

CALL N 0...2047 subroutine call at N. unchanged  one 

RET dU -4095...4095 return from the subroutine. change to dU mV one 

JMP N 0...2047 transition at N. without change one 

WAIT F 0...1 waiting for sweep or sync. without change until sync or sweep. 

LOADN T 0...4095 loading delay. without change one 

OUTN U 0...4095 output voltage. + Delay. U mV T (load command LOADN). 

DIFFN dU 0...4095 eg changing. + Delay. change to dU mV T (load command LOADN) 

OUTAUX U 0...1 voltage output (additional output) log.  0 or log. one one 

 

Macros 

_SIN N 1...2048 Output N sine samples (points) change using DIFFN N 

_COM N 0...511 Output in RS232 format. rev. to App. OUTN 7-12 - parameter dependent 

 

Macro Parameters 

For macro _SIN   

# SINF F 0...100000 Sets sine frequency in kHz (excluding #CLOCK and LOADN 1). 

   Real frequency = F / # CLOCK / T kHz. (Default 1000). 

# SINA A  0...2047 Sets the amplitude of the sine mV (default 1000). 

# SINPH  PH 0...359 Sets phase of the sine in degrees (default: 0). 

For macro _COM   

# lOG0 U 0...4095 Sets the logic zero and start bit level (default 0). 

# LOG1 U 0...4095 Sets the logic 1 level and stop bit level (default 3300). 

# BITS N 5...8 Sets the number of bits for transmission. (Default 8). 

# PRTY N 0...2 Sets parity bit 0 = off, 1 = odd, 2 = even. (Default 0). 

# SBITS N 1...2 Sets number of stop bits (1 by default). 

# DCOM N 0...1 The default command that can be skipped (omitted) 1 = _COM, 0 = OUT (default: 0). 

 

Directives 

# CLOCK  N 0...100000000 Set generator control controls to clock period = 5 * N nS. 

   If not specified, control. elements do not change when loading a file. 

# AMP A 0...100 Set generator control output amplitude = A% of that specified by the file. 

   If not specified, control. elements do not change when loading a file. 

# NOMSG  N 0...2 1 - Do not display a modal window with the results of the file compilation.  

   2 - Do not display even in case of anerror (not recommended). 

   By default, N = 0 - display a modal window. 

# BAUD N 100...200000000 Set generator control panel for the clock frequency = N Hz. 

   It has priority over the #CLOCK directive  
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   It is not always possible to set the desired frequency accurately.  

   A message is displayed about the actual frequency and the error percentage. 

# AUTOR N 0..1 1 - Automatically start the downloaded file (default = 1).  

   0 - Start by pressing the generator "ON" button. 

 

 

//================================================ ============================ 

// Task to output 5 pulses can also be solved by using REPEAT, ENDREPEAT commands.  

// This solution takes up less memory. 

# CLOCK 20;  // Set the repetition period of the clock signal = 100 nS. 

REPEAT 5;  // Sets the number of repeats = 5. 

OUT 3300; // Set the voltage of 3.3 V. 

ENDREP -3300; // Set. 0v, go to the command following the REPEAT 4 times. STOP 

0; // Set 0V and stop output 

// ================================================ ============================ 

 

The OUT command can be skipped, it is implied by default. When the REPEAT command is executed, the 
output voltage of the generator does not change. Nesting of commands REPEAT, ENDREPEAT is not 
supported. With REPEAT 0, 4096 repetitions will be performed 

 

================================================ ============================  

//Example of the DIFF command. Generator file for sawtooth output.  Voltage varies every 10 ns. 

CLOCK 1;  

OUT 0; 

 

MAIN_LOOP: 

DIFF 1;  // Increase the voltage on the 1 mV. 

REPEAT 2998; // Sets the number of repeats = 2998.  

DIFF 1;  // Increase the voltage on the 1 mV. 

ENDREP 0; 

DIFF 1;  // Increase the voltage on the 1 mV. 

REPEAT 2999; // Sets the number of repeats = 2999. 

DIFF -1;  // Reduce the voltage on the 1 mV. 

ENDREP 0; 

DIFF -1; // Reduce the voltage on the 1 mV. 

JMP MAIN_LOOP; 

//================================================ ============================  

 

//================================================ ============================  

Example using the DELAY command. Example of generator file for outputting 5 rectangular pulses 

// of 0.1 ms with 100 microsecond pause. 

# CLOCK 20;  // Set the repetition period of the clock signal = 100 ns. 

REPEAT 5;  // Sets the number of repeats = 5. 

OUT  3300;  // Sets the voltage of 3.3 V. 

OUT 0; 

DELAY 998; 

ENDREP 0;  // Does not change the voltage, go to the command following the REPEAT 4 times. 

STOP 0;  // Set to 0V and stop output. 

// ================================================ ============================ 
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DELAY N - Delay for N cycles where N up to 4095. When N = 0, delay = 4096. Does not change the voltage 
at the generator output. 

 

//================================================ ============================  

// Example of subroutine call. An example generator file for outputting 5 rectangular pulses 

// of 0.1 ms with 100 microsecond pause. 

# CLOCK 20;  // Set the repetition period of the clock signal = 100 ns. 

REPEAT 5;  // Sets the number of repeats = 5. 

OUT 3300;  // Set the voltage of 3.3 V. 

OUT 0; 

CALL my_sub; // Call subroutine (in this case, execution delay of 9998 cycles).  

ENDREP 0;  // Does not change the voltage, go to the command following the REPEAT 4 times. 

STOP 0;  // Set 0V and stop output. 

// ------------- 

my_sub:  // Subroutine label (letters, numbers and underscores). 

DELAY 4000;  

DELAY 4000; 

DELAY 1996;  // 1 clock cycle goes to the subroutine call, 1 clock cycle goes to return. 

RET 0;  // dU = 0 - does not change the voltage of the generator. 

// ================================================ ============================ 

 

CALL N - call a subroutine at address N. One time nesting of calls is allowed (return stack = 2 words). Does 
not change the voltage at the output of the generator 

RET dU - voltage change on dU and return from the subroutine. 

JMP N - go to address N. Does not change the voltage at the output of the generator. 

 

//================================================ ============================ 

// Example for implementing large delays. 

//Delay of 1,000,000 cycles.  

Repeat 1001; 

Delay 998; 

ENDREP 0; 

 

// Delay of 10,000,000 cycles 

repeat 3999; 

delay 2499; 

endrep 0; 

delay 2499; 

 

Delay of 100,000,000 cycles.  

repeat 4000; 

delay 4000; 

delay 4000; 

delay 4000; 

delay 4000; 

delay 4000; 

delay 4000; 

delay 998; 

endrep  0; 
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delay 3999; 

// ================================================ ============================ 

 

Note: Commands may be written in lower case. 

Semicolons at the end of lines may be omitted. 

 

//================================================ ==========================  

// Example of using _SIN macro 

# NOMSG 1;  //Do not display a modal window with the results of the file compilation. 

# CLOCK 50;  // clock period = 5 * 50 = 250 nS. 

# AMP 100; 

LOADN 2;  // execution time OUTN, DIFFN (in cycles). 

// set the parameters of a sinusoidal signal. 

# SINPH 0; // phase of sine in degrees. 

# SINA 1000; // Amplitude of sine in mV. 

# SINF 1000;  // Frequency in kHz (excluding #CLOCK and LOADN dividers)  

                       // In this case, frequency = 1000 / # CLOCK / LOADN = 1000/50/2 = 10 kHz. 

 

MAIN_LOOP: 

 

// Output the initial level. It will correspond to the point on the sine wave at #SINPH phase.  

// If #SINPH = 0 or 180 - it will match the DC component of the sine.  

// If #SINPH = 90 or 270 - it is the maximum level of the sinusoidal signal, etc. 

 

OUT 1500; 

 

// Output a sine signal. The macro is deployed using DIFFN command. 

// The last point is output with the DIFF command (with LOADN> 1, it leaves time for exiting from a 
subroutine or if you need to loop the script  etc.). 

 

// Number of memory locations = 200. Macro execution time = 99.75 microseconds (199 * 500 ns + 250 ns) 

 

_SIN 200;  // 200 points (samples). One period. 

DELAY 100;  // Delay 100 cycles = 25 ms. 

JMP MAIN_LOOP; 

//================================================ ========================== 

 

//================================================ ==========================  

// Example of using _COM macro. 

# AMP 100; 

# AUTOR 0;  // Disable autorun after file download (default is 1). 

# DCOM 1;  // Default command is _COM (instead OUT). 

# BAUD 9600;  // Exchange Baud rate (set clock has priority over #CLOCK). 

# PRTY 0;  // Parity bit 0 - off, 1 - odd, 2 - even. (Default 0). 

# BITS 8;  // Data Bits (5...9, default 8). 

# SBITS 1;  // Number of stop bits (1 by default). 

# LOG0 0;  // The level of logical zero and the start bit (default 0). 

# LOG1 3300;  // The level of logical one and a stop bit (default is 3300). 

OUT 3300; 

LOADN 1;  // _COM macro deployed using OUTN. 
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BYTE_0: 

_COM 0xA5;  // Output 0xA5 in RS232 format. 

BYTE_1: 

0xA5;  // Output 0xA5 in RS232 format (_COM can be omitted, because #DCOM 1). 

BYTE_2: 0x00;  // Output 0x00 in RS232 format. 

STOP 3300; 

// ================================================ ========================== 
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Expanding Frequency Range For FRA And AA 

The device in the FRA and AA modes can operate on the harmonics of the generator signal. To obtain a 
high level of harmonics in the spectrum, you can use a rectangular pulse shaper using digital logic from the 
LVC family. The fast slew rate of the ICs provides a high level of odd harmonics in the output signal even at 
high frequencies. Such pulse a shaper extends the frequency range up to 500 MHz. For further information 
see http://www.osa103.ru/en/hardware 

External modules based on ADF4351, MAX2870, MAX2871 chips and RF mixer chip are also supported. 
The modules extend the frequency range in FRA mode up to 4.4 GHz or 6.2 GHz. For further information 
see OSA-6G module online http://www.osa103.ru. 
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Installing The Software In Linux (Ubuntu) 

The program can run under Linux using Wine environment. The USB device is FT232R chip. The library 
libftd2xx.so can be obtained from http://www.ftdichip.com/. To work with this library in Wine, an additional 
wrapper is needed lin_ftd2xx.dll.so from ASIX http://www.asix.net/. All the necessary installation files 
contained in a subdirectory ../Drivers /Linux/. 

Step 1: Remove ftd2xx.dll (recommended) 

When starting, the software attempts to load wrapper library file lin_ftd2xx.dll.so. If the loading is successful, 
then the launch under Wine is assumed. If the loading fails then the software tries to load Windows library 
file ftd2xx.dll. 

To make it easier to diagnose possible installation errors, it is recommended that the ftd2xx.dll file is deleted 
from the folder with the executable program file (or make sure that it is not present). 

Step 2: Install the FTDI libftd2xx.so.1.3.6 library 

Do not use copying from this document via the clipboard to enter commands! 

Copy the file libftd2xx.so.1.3.6 to / usr / lib (here and below / usr / lib32 - for the 64-bit version of Linux). 

> sudo cp libftd2xx.so.1.3.6 / usr / lib 

Give the necessary rights (read and execute all): 

> sudo chmod 0555 /usr/lib/libftd2xx.so.1.3.6 

Create symbolic links: 

> sudo ln -s /usr/lib/libftd2xx.so.1.3.6 /usr/lib/libftd2xx.so.0 

> sudo ln -s /usr/lib/libftd2xx.so.1.3.6 /usr/lib/libftd2xx.so.1 

Step 3: Installing the wrapper library lin_ftd2xx.dll.so 

Copy lin_ftd2xx.dll.so file in /usr/lib/i386-linux-gnu/wine. 

> sudo cp lin_ftd2xx.dll.so/usr/lib/i386-linux-gnu/wine 

Give the necessary rights (read and execute all): 

> sudo chmod 0555 /usr/lib/i386-linux-gnu/wine/lin_ftd2xx.dll.so 

Step 4: Create file .rules 

The file is used to automatically authorize USB access and unload the unused and pre-installed Linux drivers 
for the COM port for this chip. 

> sudo gedit /etc/udev/rules.d/osa103.rules 

This file contains 2 lines. File contents: 

ACTION == "add", ATTRS {idVendor} == "0403", ATTRS {idProduct} == "6001", MODE = "0666" ACTION == 
"add", ATTRS {idVendor} == "0403", ATTRS {idProduct} == "6001", RUN + = "/ sbin / rmmod ftdi_sio 
usbserial" 

 

Useful Commands 

Ensure the COM port drivers are unloaded. 

> dmesg | grep -i ftdi 

 

Unload the COM port drivers manually. 

> sudo rmmod ftdi_sio 

> sudo rmmod usbserial 

 

Get USB rights. 

> lsusb 

>ls -R -l /dev/bus/usb 

 

Get USB rights manually. 

> lsusb 

> sudo chmod 0666 /dev/bus/usb/***/*** 

where * insert USB FT232 file name)  
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System Calibration And Debug Information 

To access the system calibration and debugging information it is necessary to first edit the Osa103.ini file. 
Open the file in a text editor (eg. Notepad) and add the following line under [System]: 

debug = 1 

Save the file, restart the program and then use: Menu-> File-> Debug Mode to activate the calibration and 
debug menu. 

Do not include debug mode unless intentionally needing to calibrate. Before any changes are made it is 
recommended to make a note of the factory settings from the System Calibration Window. When finished, 
edit the Osa103.ini file and delete the debug = 1 line. 

System Calibration Window 

Open with: Menu-> File-> System Calibration. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The module is first calibrated after manufacture.  

To perform calibration it is necessary to use a reference voltage meter with an error of not more than 0.2% 
when measuring a DC voltage of 3 V and a reference frequency source with an error of no more than 10E-7 
with Vpp = 0.1 ... 1 V and a frequency up to 60 MHz. 

Calibration Procedure 

Preparation 

 Set modes switches J1 and J2 to position 1-2 (see: Mode switch ). 

 Connect the module and let it warm up for 3 minutes. 

Generator Calibration 

 Connect the reference voltmeter to the generator output. 

 Press [Test 0V] button (item 2) and rotate trimmer R18 to set the voltage to 0 V. 
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 Press [3V Gain] button (item 1) and rotate trimmer R24 to set the voltage to 3 V. 

 Disconnect the voltmeter. 

Phase, Offset And Gain Matching For Interleaving ADCs 

 Connect the generator output to the oscilloscope input. 

 Press [Auto] button (item 4) and wait until the calibration is completed. 

 Press [HF FFT] button (item 5) and rotate trimmer capacitor C18 to achieve a minimum level spectral 

components with a frequency of 60 MHz. 

 Press [Auto] button (item 4) again and wait until calibration is completed. 

 Disconnect the generator output from the oscilloscope input. 

Setting Subtractive Dither Compensation 

 Typical values of: AMP = 125, RC = 2 and Phase = 175. 

 Press button [FFT] (item 10), and use the scroll bars (item 11) to achieve a minimum and uniform 

level of noise in the spectrogram. 

Calibration Of The System Frequency (VCTCXO) 

 Apply a reference frequency signal source to the analog input channel. 

 Use entry box (item 12) to set the reference source frequency. 

 Press [Auto] button (item 16) and wait until the calibration is complete. 

 Disconnect the reference source. 

Checking The Digital Channels 

 Connect the digital channels to the output of the generator with four conductors of minimum length. 

 Use threshold buttons (item 20) to select the required digital channel threshold. 

 Use frequency buttons (item 19 to select the required test frequency. 

 Test results are shown by item 18. 

DAC Distortion Correction 

Use [D. Corr.] button and scroll bar (items 21 and 22) to set the DAC R-2R ladder dynamic distortion 
correction. Recommended value:  64. 

Exit and Store Calibration 

Press the [OK] button to store the calibration in non-volatile memory and exit the System Calibration dialog. 

Debug Information 

USB 

Use: Menu-> File-> USB Debug Data to enable the display of USB debugging information. 

Strobe Mode (ETS) 

Use Menu-> File-> ETS Debug Data to enable the display of ETS debugging information. 

 


